Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-08-26 04:34:45

inukaze
Member
Registered: 2014-07-31
Posts: 29

Xfce 4.10 Globalmenu

Hi there, i am under Debian Jessie Stable, and the official version here is Xfce 4.10 and its the lastest available from repo. (I dont use repos from third-party) .

Well , i try to put "Globalmenu" / "appmenu" / "macmenu" / "topmenu" . but i can't get it to work

The unique compile without errors or unresolved dependence is "topmenu" the readme says to put

GTK_MODULES="canberra-gtk-module:topmenu-gtk-module"

inside the file

$HOME/.gtkrc-2.0

But dont work, i try with

# TopMenu / MacMenu
GTK_MODULES="topmenu-gtk-module:canberra-gtk-module"
export GTK_MODULES=topmenu-gtk-module:canberra-gtk-module

neither work.

Someone have a version compatible with this version of Xfce ???

Offline

#2 2016-08-26 10:20:33

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,979

Re: Xfce 4.10 Globalmenu

Try:

gtk-modules = "canberra-gtk-module:topmenu-gtk-module"

...in ~/.gtkrc-2.0, or put:

GTK_MODULES="topmenu-gtk-module:canberra-gtk-module"

...in your ~/.xprofile or ~/.xinitrc.

Offline

#3 2016-08-31 01:46:33

inukaze
Member
Registered: 2014-07-31
Posts: 29

Re: Xfce 4.10 Globalmenu

Thank you for your answer. with the first line , works i waited big_smile


Debian_8_Jessie_Xfce4_Top_Menu_Maximus.pngsubir gif

This is my :
Debian Xfce 4.10 + TopMenu + Windowck + Maximus + DockBarX

sudo apt-get install -y valac ; \
sudo apt-get install -y maximus ; \
sudo apt-get install -y zeitgeist ; \
sudo apt-get install -y libwnck-dev ; \
sudo apt-get install -y python-wnck ; \
sudo apt-get install -y python-xlib ; \
sudo apt-get install -y gconf-editor ; \
sudo apt-get install -y libgtk2.0-dev ; \
sudo apt-get install -y libglib2.0-dev ; \
sudo apt-get install -y python-imaging ; \
sudo apt-get install -y python-keybinder ; \
sudo apt-get install -y libxfce4ui-1-dev ; \
sudo apt-get install -y libwnckmm-1.0-0-dev ; \
sudo apt-get install -y libpanel-applet-4-0 ; \
sudo apt-get install -y libpanel-applet-4-dev ; \
sudo apt-get install -y gir1.2-panelapplet-4.0 ; \
sudo apt-get install -y indicator-session-gtk2 ; \
sudo apt-get install -y xfce4-panel ; \
sudo apt-get install -y xfconf ; \
sudo apt-get install -y libxfconf-0-dev ; \
sudo apt-get install -y xfce4-panel-dev ; \
sudo apt-get install -y libvala-0.26-dev
sudo apt-get install -y libcanberra-gtk-module ; \
sudo apt-get install -y libcanberra-dev ; \
sudo apt-get install -y libcanberra-gtk-dev ; \
sudo apt-get install -y libbamf0 ; \
sudo apt-get install -y bamfdaemon

# TopMenu
git clone https://git.javispedro.com/cgit/topmenu-gtk.git
cd topmenu-gtk
autoreconf --install ; ./configure --prefix=/usr ; make ; sudo make install ; sudo ldconfig ; mv "$HOME/.gtkrc-2.0" "$HOME/.gtkrc-2.0.original"
echo 'gtk-modules = "canberra-gtk-module:topmenu-gtk-module"' >> "$HOME/.gtkrc-2.0"

# Windowck
git clone https://github.com/cedl38/xfce4-windowck-plugin ; cd xfce4-windowck-plugin
./autogen.sh --prefix=/usr ; ./configure --prefix=/usr ; make ; sudo make install ; sudo ldconfig

# DockBarX
git clone https://github.com/M7S/dockbarx ; \
cd dockbarx ; \
sudo ./setup.py install ; cd ..
git clone https://github.com/TiZ-EX1/xfce4-dockbarx-plugin ; \
cd xfce4-dockbarx-plugin/ ; \
./waf configure --prefix=/usr ; \
./waf build ; \
sudo ./waf install ; \
sudo ldconfig ; \
mkdir -p "$HOME/.dockbarx/themes" ; cd .. ; killall -9 xfce4-panel

Offline

Board footer

Powered by FluxBB