Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-01-19 20:51:57

92scarface
Member
Registered: 2017-01-19
Posts: 4

Panel is shown as active program in plank

Hello,

I just installed XFCE yesterday and like it quite much with plank as a dock, the only issue is that the top panel is being recognised as an active program and is shown all the time in my dock.
Does anyone have an idea how to resolve this?

Greetings,
92scarface

Offline

#2 2017-01-20 02:58:03

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: Panel is shown as active program in plank

Perhaps its a bug with plank. I've installed plank and can't replicate the issue. Can you post back the results of:

wmctrl -lv

...so we can see a listing of your active windows and the "desktop number" of the xfce4-panel app (which should be -1).

Also, which version of plank are you using?

As a test, can you also restart the panel:

xfce4-panel -r

...and see if that makes a difference with it displaying on the dock?

Offline

#3 2017-01-21 19:07:46

92scarface
Member
Registered: 2017-01-19
Posts: 4

Re: Panel is shown as active program in plank

Thank you for the quick reply ToZ. When I restart the panel it vanishes from the dock. The other command however does not seem to work, I forgot to mention I am on arch linux (do not know if it is important) and I just installed the newest version from the AUR.

Last edited by 92scarface (2017-01-21 19:10:32)

Offline

#4 2017-01-22 01:13:05

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: Panel is shown as active program in plank

92scarface wrote:

Thank you for the quick reply ToZ. When I restart the panel it vanishes from the dock. The other command however does not seem to work, I forgot to mention I am on arch linux (do not know if it is important) and I just installed the newest version from the AUR.

Does the same happen with the stable version from the repositories (not AUR)?

Offline

#5 2017-01-22 19:01:12

92scarface
Member
Registered: 2017-01-19
Posts: 4

Re: Panel is shown as active program in plank

I wil have to correct myself the version I installed was from the community repos and not the AUR. The panel is now normally no longer shown in plank as long as I do not activate the panel settings, then it just stays there like before an I can not close it.

Offline

#6 2017-01-22 23:58:56

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: Panel is shown as active program in plank

Get it to show up in plank and then in a terminal window, run:

wmctrl -lv

...and post back the results.

Offline

#7 2017-01-23 05:04:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: Panel is shown as active program in plank

I've been able to replicate the bug. I can get the preferences dialog to display if I restart the panel with the preferences window open. Then the next time I select panel preferences, the second icon appears. The bug disappears if I restart xfce4-panel again (with no preference windows open) or restart plank.

I guess somehow plank is keeping track of the previous panel ID and using that as a comparison point and, since its seeing two different panel identities, it assumes they are different.

Probably best to file a plank bug report.

Offline

#8 2020-05-13 03:34:01

roachsinai
Member
Registered: 2020-05-13
Posts: 1

Re: Panel is shown as active program in plank

Seems this bug still there, I can reproduce it.

Offline

#9 2020-05-13 11:37:43

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: Panel is shown as active program in plank

Offline

Board footer

Powered by FluxBB