Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-07-23 20:54:34

badpenguin
Member
Registered: 2017-07-23
Posts: 6

[SOLVED] xfwm: how to use workspace only on 1st monitor?

I've a dual screen setup. I use the second monitor mainly to show videos, movies and logs from servers while i work exclusively using 4 workspaces only on primary monitor.

If using xfwm then it will switch apps on 2nd monitor too like it was an extension of the 1st one; is there a way to stop this behavior?

Actually cinnamon has an option for it.

Is it possibile to do the same in xfwm?

Or, as alternative, are "awesome" or "i3" usable as a drop-in replacement for xfwm?
I already tested those 2 WMs and both have support for separated workspaces on every monitor.

Thanks.

Last edited by badpenguin (2017-07-24 16:55:43)

Offline

#2 2017-07-23 21:18:05

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,696

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

Hello and welcome.

One way to do this, is when you have the apps set up on the second monitor, select "Always on visible workspace" from the window menu of each app.

Or you can use a utility like devilspie to do this automatically.

Offline

#3 2017-07-23 21:35:46

badpenguin
Member
Registered: 2017-07-23
Posts: 6

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

ToZ wrote:

Hello and welcome.

One way to do this, is when you have the apps set up on the second monitor, select "Always on visible workspace" from the window menu of each app.

Or you can use a utility like devilspie to do this automatically.

Thanks i already knewed that, sorry to forget to mention.
That's not what i'm looking for: Workspaces must be separated per monitor.

Offline

#4 2017-07-23 22:01:53

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,696

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

That functonality doesn't currently exist in Xfce. If you want the functionality, you'll need to resort to workarounds. There is however, this existing enhancement request:
https://bugzilla.xfce.org/show_bug.cgi?id=13634

Offline

#5 2017-07-23 22:35:29

badpenguin
Member
Registered: 2017-07-23
Posts: 6

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

ToZ wrote:

That functonality doesn't currently exist in Xfce. If you want the functionality, you'll need to resort to workarounds. There is however, this existing enhancement request:
https://bugzilla.xfce.org/show_bug.cgi?id=13634

Thanks. Then i will try replacing it with "awesome"; any WM will work with xfce or  has xfwm something special?

Offline

#6 2017-07-23 23:37:09

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,696

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

I've never tried replacing it, but I have read that others have had success. Xfce is built to be modular.

You'll need to prevent xfwm4 from starting up - there are a couple of options for this. One is to set it's Restart Style to Never in Settings Manager > Session and Startup > Session. The other is to override the xfwm4 executable by placing a blank file at /usr/local/bin/xfwm4. You'll also need to create a startup entry for the new window manager.

Offline

#7 2017-07-23 23:49:45

badpenguin
Member
Registered: 2017-07-23
Posts: 6

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

ToZ wrote:

I've never tried replacing it, but I have read that others have had success. Xfce is built to be modular.

You'll need to prevent xfwm4 from starting up - there are a couple of options for this. One is to set it's Restart Style to Never in Settings Manager > Session and Startup > Session. The other is to override the xfwm4 executable by placing a blank file at /usr/local/bin/xfwm4. You'll also need to create a startup entry for the new window manager.

Thank. I'll go for creating a custom session startup profile and forking the startxfce4 script in a way that does not call xfce4-session smile

Offline

#8 2017-07-24 00:10:24

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,696

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

badpenguin wrote:

I'll go for creating a custom session startup profile and forking the startxfce4 script in a way that does not call xfce4-session smile

You still need a session manager to run. It's only xfwm4 that you don't want executing.

Offline

#9 2017-07-24 16:16:56

badpenguin
Member
Registered: 2017-07-23
Posts: 6

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

ToZ wrote:
badpenguin wrote:

I'll go for creating a custom session startup profile and forking the startxfce4 script in a way that does not call xfce4-session smile

You still need a session manager to run. It's only xfwm4 that you don't want executing.

Ok i got it working but honestly i don't like those "tiling" window manager.
I also tried like 20 window managers but only a few does work the way i like; unlucky those depends on gnome, *damn* smile

Lets try an alternative approach with xfwm4.

Is it possibile  to create an hotkey that pressing Meta+e will:
- move window to 2nd monitor
- maximize it (or better just 100% height)
- set the sticky flag

EDIT: i've found this script https://github.com/jc00ke/move-to-next-monitor
but need to find wich is the correct option to pass to wmctrl to keep the window sticky when changing the workspace

Last edited by badpenguin (2017-07-24 16:28:59)

Offline

#10 2017-07-24 16:55:20

badpenguin
Member
Registered: 2017-07-23
Posts: 6

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

Solved by adding:
wmctrl -ir $window_id -b toggle,sticky

add the end of: https://github.com/jc00ke/move-to-next-monitor

and then creating a keybind for it.

Offline

#11 2017-07-24 19:48:46

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,696

Re: [SOLVED] xfwm: how to use workspace only on 1st monitor?

Nice. Thanks for sharing the solution.

Offline

Board footer

Powered by FluxBB