Xfce Forum

Sub domains

You are not logged in.

#1 2018-01-15 01:06:43

From: Perth, Australia
Registered: 2018-01-11
Posts: 20

[SOLVED] xinitrc not found in tinycorelinux xfce4-session


Attempted to compile xfce4-session to a 64 bit TinycoreLinux which is a ramdrive system and default prefix=/usr/local
In following the build order from xfce docs I have only built to xfce-session and not yet xfdesktop or higher in case that is an issue and that I am pre-mature to try testing a graphical environment.

Booted into openbox, loaded xfce4-session, logged out to console prompt as no login manager is running and ran as non-root

startxfce4 --with-ck-launch

output was 2 lines with line one paraphrased as "Starting X server"
second line xinitrc not found.

2) I have copied the /usr/local/etc/xdg/xinitc to

but as you can tell I am not very good at building a new graphical environment.

not even sure I should copy as a dot file or a normal file name heh heh

3) TinyCore normally uses a .xsession to start the graphical environment and I will show the openbox variant in case I am advised to edit this instead?

/usr/local/bin/Xorg -nolisten tcp &
export XPID=$!
waitforX || ! echo failed in waitforX || exit
"$DESKTOP" 2>/tmp/wm_errors &
export WM_PID=$!
[ -x $HOME/.setbackground ] && $HOME/.setbackground
[ -x $HOME/.mouse_config ] && $HOME/.mouse_config &
[ $(which "$ICONS".sh) ] && ${ICONS}.sh &
[ -d "$HOME/.X.d" ] && find "$HOME/.X.d" -type f -print | while read F; do . "$F"; done

forgot to mention Tinycore has no xserverrc file, if that makes a difference

Thanks for reading

in openbox, thunar, panel and xfce4-settings-manager GUI all open correctly and appear to work as is

consolekit (ck) is loaded.

The xsession VARIABLES eg HOME are defined elsewhere in the TC scripts

thanks for reading

Last edited by aus9 (2018-01-15 11:36:32)


#2 2018-01-15 11:35:54

From: Perth, Australia
Registered: 2018-01-11
Posts: 20

Re: [SOLVED] xinitrc not found in tinycorelinux xfce4-session

Ok  had some success

edit of that xsession file
added new secondline same as my console startxfce line and I got to XFCE

There are some glitches and its not useful but I can now test

thanks for reading


Board footer

Powered by FluxBB