Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-03-12 22:47:28

aklaing
Member
Registered: 2018-03-12
Posts: 2

How to change key bindings for xfce-terminal ?

I have used the instructions quoted below for an older version of xfce-terminal on xubuntu 16.04 and it worked.  The source is on the last line of the quote.
I have just upgraded to xubuntu 18.04 LTS beta (daily build as of March 12), and the instructions below don't seem to work anymore.
Any ideas how I could get this to work?

# use the following to create keybindings for
# the xfce terminal.
#
# Start (Mouse) Button -> Settings -> Appearance -> Settings (fourth tab) -> CHECK the Third checkbox under "Menus and Buttons" ie "Enable Editable Accelerators"
#
# Create a terminal, and use menu to create an extra tab in it.
#
# Open the menu item for "Tabs", and hover over each of the first four items, and while hovering, type your preferred keyboard shortcut.
#
# Source/Credit:
# http://docs.xfce.org/faq
# http://docs.xfce.org/xfce/xfce4-setting … nd_buttons

Thank you,

Ambrose

Offline

#2 2018-03-12 23:13:35

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,381

Re: How to change key bindings for xfce-terminal ?

Hello and welcome.
You're probably using a gtk3 build of xfce4-terminal. The "hover and change accelerator" is a GTK2 feature.

To change the keyboard shortcuts in a gtk3 build of xfce4-terminal, edit the file ~/.config/xfce4/terminal/accels.scm, find the action/shortcut you want to change, remove the leading ";" (semicolon) from the line and change the shortcut at the end of line.

Save the file and quit all instances of and restart xfce4-terminal.

Online

#3 2018-03-13 16:05:21

aklaing
Member
Registered: 2018-03-12
Posts: 2

Re: How to change key bindings for xfce-terminal ?

Thank you -- your advice resolved the issue!
Best regards

Offline

#4 2020-03-14 09:51:19

trebla
Member
Registered: 2020-03-14
Posts: 1

Re: How to change key bindings for xfce-terminal ?

Hi. This didn't work for me. I tried changing the shortcut for new tab to Ctrl-t in ~/.config/xfce4/terminal/accels.scm. More specifically changing the line:

; (gtk_accel_path "<Actions>/terminal-window/new-tab" "<Primary><Shift>t")

to

(gtk_accel_path "<Actions>/terminal-window/new-tab" "<Primary>t")

but nothing happened. The shortcut for opening a new tab is still Ctrl-Shift-t. And when I restart xfce4-terminal the line changes back and my change was overwritten. In the beginning of the file it says:

; this file is an automated accelerator map dump

so I guess this has to be changed somewhere else.

I have xfce4-terminal 0.8.8. ldd shows it is linked to libgtk-3.so.0, so the old gtk trick doesn't work either.


Edit.

I worked around this by patching the source. On gentoo this is easy by creating the directory /etc/portage/patches/x11-terms/xfce4-terminal and dropping the patch there. Here is my patch that changes three shortcuts:

https://gist.github.com/AlbertVeli/71ab … b189bdff0a

Please respond to this post if you find another way to permanently change the shortcuts.

Regards,

Albert - treblA

Last edited by trebla (2020-03-14 10:20:56)

Offline

#5 2020-03-14 10:53:54

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,381

Re: How to change key bindings for xfce-terminal ?

Hello and welcome to the forums trebla.

It looks like you need to make the change when there are no instances of xfce4-terminal running. If it is running, it will overwrite the setting on exit.

Online

Board footer

Powered by FluxBB