Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-10-24 23:46:59

ModularDesign
Member
Registered: 2018-10-24
Posts: 1

Plank Dock appears with a 1 minute delay after logging out and then in

I am running Debian 9.5 stable with Xfce..

First I deleted the bottom panel and then I installed the plank dock by : sudo apt-get install plank

then I added plank to the startup in "Session and Startup" ...

when I restart the system the plank dock appears instantly and without delay and there are no bugs ...

but when I log out and then in it takes 1 minute for the dock to load/appear and even then when I launch multiple instances of a program in the dock, they don't show up in the right click menu of the program icon in the dock...there are also no indicators in the dock(normally there is a one dot or two dots indicator)...


Many Thanks

Offline

#2 2020-04-12 08:47:09

toketin90
Member
Registered: 2020-04-12
Posts: 2

Re: Plank Dock appears with a 1 minute delay after logging out and then in

Hi, sorry if I open again this old post, but on my Archlinux machine I'm facing your same issue. Have you found any fix?

I'm running Xfce 4.14.2 and Plank 0.11.89.

Thanks
Marco

Offline

#3 2020-04-12 12:05:07

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Plank Dock appears with a 1 minute delay after logging out and then in

Hello and welcome.

How do you start xfce? Do you use a display manager (and if so, which one) or startx (if so, can you post your ~/.xinitrc)?

Is your dbus set up properly:

env | grep DBUS_SESSION

And finally, after a reboot and fresh login, have  look at your log files for anything relevant:
- ~/.xsession-errors (if being used)
- "journalctl -b 0"
- "journalctl -u bamfdaemon"

Offline

#4 2020-04-16 13:18:52

toketin90
Member
Registered: 2020-04-12
Posts: 2

Re: Plank Dock appears with a 1 minute delay after logging out and then in

ToZ wrote:

Hello and welcome.

How do you start xfce? Do you use a display manager (and if so, which one) or startx (if so, can you post your ~/.xinitrc)?

Is your dbus set up properly:

env | grep DBUS_SESSION

And finally, after a reboot and fresh login, have  look at your log files for anything relevant:
- ~/.xsession-errors (if being used)
- "journalctl -b 0"
- "journalctl -u bamfdaemon"

Hi, I'm using lightdm as login manager, I've seen that if I wait a few seconds before login back Plank starts correctly. So maybe it's due to the time cycle of bamfdaemon itself.

~ » env | grep DBUS_SESSION                                   
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus

Last edited by toketin90 (2020-04-16 13:20:24)

Offline

#5 2020-04-16 14:26:17

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: Plank Dock appears with a 1 minute delay after logging out and then in

toketin90 wrote:

Hi, I'm using lightdm as login manager, I've seen that if I wait a few seconds before login back Plank starts correctly. So maybe it's due to the time cycle of bamfdaemon itself.

Seems like it is. How about creating a startup delay for plank by editing it's .desktop file in ~/.config/autostart? Or filing a bug report against the plank product?

~ » env | grep DBUS_SESSION                                   
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus

This looks fine. Sometimes dbus mis-configurations lead to delays.

Offline

#6 2020-04-18 22:40:04

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 253

Re: Plank Dock appears with a 1 minute delay after logging out and then in

I been using Plank for a couple weeks now. This morning I upgraded my system to MX19 and 4.14. When I first installed Plank I started it from the menu and it started right away. I then added it to the session/autostart via the settings manager but it would always fail to start on login. I looked at the .desktop file that was created through settings and it looked fine but no go. What I did was delete the automatically created file and dragged the .desktop file in from /usr/share/applications and now it opens once the desktop is up after a login.


Siduction
Debian Sid
Xfce 4.14

Offline

#7 2022-04-29 20:20:06

blackhole.cyber
Member
Registered: 2022-04-29
Posts: 1

Re: Plank Dock appears with a 1 minute delay after logging out and then in

I was using plank in gnome and I did not have this problem, but in xfce, when I logged in to Linux for the first time, I had no problem, but after logout and re-login, plank had this problem and it took a few minutes to run, and after execution, it did not display item indicators. I was involved with it for a while and I was able to fix it.
Follow this path to solve this problem …

Enter the Settings > Session and Startup > Application Autostart [Tab] >  click [ + ]  Add application >

Name: Kill user processes
Description: …
Command: killall -u <Enter your username here>
Trigger: on logout

After this, click on the OK button to save the settings for you
Logout and login several times and test the result …


My PC specs:

OS: Arch Linux x86_64
Kernel: 5.15.36-1-lts
Plank Version: 0.11.89-4
Resolution: 2560x1440
DE: Xfce 4.16
WM: Xfwm4
CPU: Intel Xeon X5680 (12) @ 3.334GHz
GPU: NVIDIA GeForce GTX 1050 Ti

Last edited by blackhole.cyber (2022-04-29 23:20:27)

Offline

Board footer

Powered by FluxBB