Xfce Forum

Sub domains

You are not logged in.

#1 2018-12-11 12:26:19

Registered: 2018-12-11
Posts: 1

Failed to activate service 'org.xfce.FileManager'

Hi all

I use Kali with xfce4 desktop environment. And before update system work good.
After update , when I try to open some files from desktop i have some errors in log - journalctl -b i see:

Nov 27 19:02:31 kalin dbus-daemon[812]: [session uid=0 pid=812] Activating via systemd: service name='org.xfce.FileManager' unit='thunar.service' requested by ':1.17
Nov 27 19:02:31 kalin systemd[781]: Starting Thunar file manager...
Nov 27 19:02:31 kalin systemd[781]: Started Thunar file manager.
Nov 27 19:04:31 kalin dbus-daemon[812]: [session uid=0 pid=812] Failed to activate service 'org.xfce.FileManager': timed out (service_start_timeout=120000ms)

I already try to clear .cache folder
Reinstall Thunar, xfce4.
Change lightdm to gdm3
Problem not solved.

I try clear install from kali-linux-xfce-2018-W47-amd64.iso - and have this issue after install.
uname -a - Linux alin 4.18.0-kali2-amd64 #1 SMP Debian 4.18.10-2kali1 (2018-10-09) x86_64 GNU/Linux


#2 2018-12-15 02:01:58

From: Canada
Registered: 2011-06-02
Posts: 10,670

Re: Failed to activate service 'org.xfce.FileManager'

Hello and welcome.

Had a look at my kali install and it looks like something is preventing it from working under the root profile. It works fine if you use a regular user profile. There must be some sort of block somewhere that is preventing root from accessing (dbus?)

I was going to suggest creating a bug report with kali, but I realized that you had already created one. That is the best place to get a resolution.

Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---


Board footer

Powered by FluxBB