Xfce Forum

Sub domains

You are not logged in.

#1 2019-02-02 00:01:15

Registered: 2011-10-16
Posts: 286


I think I buggered things up smile I tried out budgie desktop, decided I really didn't like and uninstalled. But, now every time I start a terminal (xfce4-terminal, but it's actually a bash message) I get:

  bash: /etc/profile.d/vte.sh: No such file or directory

So, I deleted the vte files in /etc/profile.d. Nope ... not the right thing to do!

But, now I have still have the warning, and I cannot figure out how to get the vte files back. Synaptic shows that they are part of libvte-2.91.common but reinstalling that package doesn't put any new files in /etc/profile.d.  And, even if it did ... I think the error would still be there.



#2 2019-02-02 02:47:05

From: right by Jesus, our Saviour
Registered: 2013-06-15
Posts: 819

Re: vte.sh

Ubuntu package libvte-2.91-common includes file /etc/profile.d/vte-2.91.sh.  i have no idea how it ends up with the name /etc/profile.d/vte.sh but my system has the file with the version in it.  i renamed my copy to a weird name and don't get the error message.  so i presume you need to enable it somehow and then it might copy or rename the file and modify things to source it.

i only have the one file.  i don't specifically use it and don't get any such message on my 16.04 system.

lt2a/forums /home/forums 9> ls -Al /etc/profile.d
total 20
-rw-r--r-- 1 root root   40 Feb 16  2017 appmenu-qt5.sh
-rw-r--r-- 1 root root  825 Jul 19  2018 apps-bin-path.sh
-rw-r--r-- 1 root root  663 May 18  2016 bash_completion.sh
-rw-r--r-- 1 root root 1003 Dec 29  2015 cedilla-portuguese.sh
-rw-r--r-- 1 root root 1941 Mar 16  2016 vte-2.91.sh
lt2a/forums /home/forums 10>

look in file /etc/profile to see if there is any code in there that references vte.sh.  if there is, you might want to edit it and comment where it references it.  mine does not.

if you have vte-2.91.sh you might want to copy it to vte.sh in there.

my /etc/profile is:

# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if [ "$PS1" ]; then
  if [ "$BASH" ] && [ "$BASH" != "/bin/sh" ]; then
    # The file bash.bashrc already sets the default PS1.
    # PS1='\h:\w\$ '
    if [ -f /etc/bash.bashrc ]; then
      . /etc/bash.bashrc
    if [ "`id -u`" -eq 0 ]; then
      PS1='# '
      PS1='$ '

if [ -d /etc/profile.d ]; then
  for i in /etc/profile.d/*.sh; do
    if [ -r $i ]; then
      . $i
  unset i

Last edited by Skaperen (2019-02-02 03:07:52)


#3 2019-02-02 18:32:51

Registered: 2011-10-16
Posts: 286

Re: vte.sh

Thanks. The problem was I didn't have vte-2.91.sh. So, I grabbed the vte source from: http://www.linuxfromscratch.org/blfs/vi … e/vte.html and copied the vte.sh file from it to /etc/profile.d/vte-2.91.sh and all works. I really don't understand why synaptic shows that the vte files are in packages but they don't don't install with the --reinstall option. Oh well ... seems to be working now.


#4 2020-03-04 14:44:18

Registered: 2020-03-04
Posts: 1

Re: vte.sh

Could you explain in a bit more detail how you 'copied' the vte.sh file to /etc/profile.d/vte-2.91.sh?

What command did you use to copy, did you overwrite the current file?


#5 2020-03-07 02:37:00

Registered: 2011-10-16
Posts: 286

Re: vte.sh

As root I changed the copied the vte file I got to /etc/profile/.d

   sudo cp vte..whatever /etc/profile.d

Next, create a link to it:

    cd /etc/profile.d
    sudo ln -s vte.sh vte..whatever

Note: "..whatever" represents the name of the file you got. Clear as mud??? Caution, I did this about a year ago so my recollection of the details is fuzzy.


#6 2020-04-23 10:02:16

From: UK, London
Registered: 2020-04-22
Posts: 7

Re: vte.sh

here is something that may help if nothing has worked out:

1. Use debugfs to view a filesystems log

$ debugfs -w /dev/mapper/wks01-root

2. At the debugfs prompt

debugfs: lsdel

3.Sample output

Inode  Owner  Mode    Size    Blocks   Time deleted
23601299      0 120777      3    1/   1 Tue Mar 13 16:17:30 2012
7536655      0 120777      3    1/   1 Tue May  1 06:21:22 2012
2 deleted inodes found.
(there's also another approach that this www.mspy.com article suggests)
after that, things should go simply.
4. Run the command in debugfs

debugfs: logdump -i <7536655>

5. Determine files inode


output truncated
    Fast_link_dest: bin
    Blocks:  (0+1): 7235938
  FS block 7536642 logged at sequence 38402086, journal block 26711
    (inode block for inode 7536655):
    Inode: 7536655   Type: symlink        Mode:  0777   Flags: 0x0   Generation: 3532221116
    User:     0   Group:     0   Size: 3
    File ACL: 0    Directory ACL: 0
    Links: 0   Blockcount: 0
    Fragment:  Address: 0    Number: 0    Size: 0
    ctime: 0x4f9fc732 -- Tue May  1 06:21:22 2012
    atime: 0x4f9fc730 -- Tue May  1 06:21:20 2012
    mtime: 0x4f9fc72f -- Tue May  1 06:21:19 2012
    dtime: 0x4f9fc732 -- Tue May  1 06:21:22 2012
    Fast_link_dest: bin
    Blocks:  (0+1): 7235938
No magic number at block 28053: end of journal.

6.With the above inode info run the following commands

# dd if=/dev/mapper/wks01-root of=recovered.file.001 bs=4096 count=1 skip=7235938
# file recovered.file.001
file: ASCII text, with very long lines

Files been recovered to recovered.file.001.

here is an undelete-files guide for references.

~ we accept the love (and software) we think we deserve ~


#7 2024-03-19 14:03:11

Registered: 2024-03-19
Posts: 1

Re: vte.sh

in this video u can find ur answer:

step by step tutorial on how to fix bash: /etc/profile.d/vte.sh: No such file or directory on Ubuntu Linux operating system

Last edited by ToZ (2024-03-19 18:36:35)


#8 2024-03-19 18:38:03

From: Canada
Registered: 2011-06-02
Posts: 11,000

Re: vte.sh

@zarir, welcome to the forum, and thanks for the contribution.

Please don't post links to videos answering questions, but rather answer the question itself or provide information textually so everyone can benefit from the knowledge.

Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---


Board footer

Powered by FluxBB