Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-08-14 06:52:44

qx4vv9a
Member
Registered: 2019-08-12
Posts: 26

how to enable bold fonts as default system font (appearance menu)?

they are displayed properly in the drop down menu but don't work on my arch.
how to enable them?
if not possible how to get 'window button font' bold in gtk-3.0/gtk.css?

thanks in advance,
Tim

Last edited by qx4vv9a (2019-08-14 06:57:06)

Offline

#2 2019-08-14 09:17:03

qx4vv9a
Member
Registered: 2019-08-12
Posts: 26

Re: how to enable bold fonts as default system font (appearance menu)?

found this:

/* Change Xfce panel (gtk3) font weight */
.xfce4-panel {
	font-weight: bold;
}

but why does 'xfce4 appearance menu' not accept bold fonts?

Offline

#3 2019-08-14 10:51:49

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,525

Re: how to enable bold fonts as default system font (appearance menu)?

Interesting. I wonder whether the theme's font setting is taking preference? You've found a way to work around it, but it might be worth creating a bug report for.

Offline

#4 2019-08-15 05:43:57

qx4vv9a
Member
Registered: 2019-08-12
Posts: 26

Re: how to enable bold fonts as default system font (appearance menu)?

after some switching/togggling in appearance menu bold font was applied to my apps' windows but neither to the window button
nor to appearance menu itself. strange behavior i would say and an odd flashing notifyd message after reboot about 'engaged keys'
(i can't translate properly) which is not logged in protocol.
anayway, i got my settings back.
Tim

Last edited by qx4vv9a (2019-08-15 05:44:31)

Offline

#5 2022-11-15 19:39:09

oldrust
Member
Registered: 2021-01-05
Posts: 10

Re: how to enable bold fonts as default system font (appearance menu)?

I'm using the latest development packages and the same behavious applies. Only Regular font style is applied, no bold no thin.

Offline

#6 2022-11-15 20:49:27

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,525

Re: how to enable bold fonts as default system font (appearance menu)?

oldrust wrote:

I'm using the latest development packages and the same behavious applies. Only Regular font style is applied, no bold no thin.

Does it still not work even after you reboot your computer? Set the font to bold, reboot, and see if it takes effect on restart. (Here is a GTK bug report where anti-aliasing doesn't take effect until restart - maybe its related.).

Also, post back the contents of ~/.config/gtk-3.0/settings.ini if you have it.

For the record, I'm not seeing it change either but I have a lot of customization on this computer.

Offline

#7 2022-11-15 21:52:46

oldrust
Member
Registered: 2021-01-05
Posts: 10

Re: how to enable bold fonts as default system font (appearance menu)?

Tried rebooting and it doesn't help. Still only regular style.

This is my ~/.config/gtk-3.0/settings.ini

 [Settings]
gtk-theme-name = Greybird
gtk-icon-theme-name = Delft
gtk-font-name = Montserrat 9
gtk-sound-theme-name = Yaru
gtk-cursor-theme-name = BMZ 
gtk-cursor-theme-size = 24
gtk-application-prefer-dark-theme = 0
gtk-button-images = 1
gtk-menu-images = 1
gtk-overlay-scrolling = 0
gtk-enable-primary-paste = 0
gtk-primary-button-warps-slider = 0
gtk-enable-animations = 1
gtk-enable-event-sounds = 1
gtk-enable-input-feedback-sounds = 1
gtk-dialogs-use-header = 0
gtk-recent-files-enabled = 1
gtk-recent-files-max-age = 20
gtk-xft-antialias = 1
gtk-xft-hinting = 1
gtk-xft-hintstyle = hintslight
gtk-xft-rgba = rgb
gtk-xft-dpi=86 

Offline

#8 2022-11-15 23:04:10

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,525

Re: how to enable bold fonts as default system font (appearance menu)?

Try commenting out or removing the "gtk-font-name" entry and trying again. Both the immediate and restart tests.

Then try re-adding it like this:

gtk-font-name = Montserrat Bold 9

...assuming there is a Montserrat Bold font, and re-doing the tests.

Last edited by ToZ (2022-11-15 23:07:52)

Offline

#9 2022-11-15 23:07:12

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,525

Re: how to enable bold fonts as default system font (appearance menu)?

This is probably why: https://gitlab.gnome.org/GNOME/gtk/-/issues/2484. Looks like you need to manually set it outside of the settings app, in css like @qx4vv9a did.

Offline

Board footer

Powered by FluxBB