Xfce Forum

Sub domains

You are not logged in.

#1 2019-10-23 22:19:16

Registered: 2016-08-04
Posts: 14

XFCE 4.14, Xubuntu 19.10: Suspend resumes with blank screen, TTY works

When I resume from suspend I see a mouse cursor for a few seconds, then a black screen.
Both monitors say (via led color) that they're receiving video input.
I can get to a functional TTY via CTRL-ALT-F1, but when I try CTRL-ALT-F7 or F8 I get the same black screen.
I can't see anything unusual happening when it goes into suspend.

When booted into GUI, lock screen and screensaver work, although only 1 monitor is active.

Suspend worked pretty well on 19.04 (previous xfce).

I've tried disabling "Lock Screen with System Sleep" on Screensaver Preferences.
On XFCE Power Manager, I've tried setting "Lock screen when system is going to sleep" to on and off.

How should I go about diagnosing this?

- A fresh install of Xubuntu 19.10.
- Linux Kernel: 5.3.0-19-generic (x86_64).
- CPU: Core i3-3220.
- GPU: Radeon RX480 (Sapphire) - I've tried both the default and Oibaf PPA drivers.
- Monitors:
  - 0: HDMI - 1920x1200 (LHS, top-left=0x0) - DELL.
  - 1: Dual DVI - 2560x1440 (RHS, top-left=1920x0, primary) - QNIX.

Thanks for all assistance.

Last edited by xaxazak (2019-10-23 22:19:51)


#2 2019-11-04 21:26:36

Registered: 2018-01-05
Posts: 29

Re: XFCE 4.14, Xubuntu 19.10: Suspend resumes with blank screen, TTY works

I suspect you are running light-locker. This sounds like an issue that has been traced to light-locker. Work-around is to replace it with xscreensaver.


Board footer

Powered by FluxBB