Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-01-06 22:35:07

gnx
Member
Registered: 2020-01-06
Posts: 3

Plugging HDMI cable on laptop spams Display window and doesn't work

I have a laptop Acer Nitro AN515-51 with  NVIDIA GeForce GTX 1050 and Intel HD Graphics 630.
I just installed MX Linux.

Problem: External monitor can't be detected by xrandr and the Display window keeps spamming, when i plug the cable, in less than 1 second I have 4 or 5 Display windows and it keeps going like that.
When I say Display window I'm referring to the window where you can configure screen settings and layout.

I have used arch with XFCE before and the dual monitor thing only works when I use nvidia proprietary drivers, specifically using the nvidia-xrun script.

Offline

#2 2020-01-07 12:01:13

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,378

Re: Plugging HDMI cable on laptop spams Display window and doesn't work

Hello and welcome.

See if you have a keyboard shortcut set for "Display" in Settings Manager > Keyboard > Application Shortcuts. If there is one, delete it and see if that helps.

Offline

#3 2020-01-07 12:28:14

gnx
Member
Registered: 2020-01-06
Posts: 3

Re: Plugging HDMI cable on laptop spams Display window and doesn't work

Yes, there is no more display settings when I plug it and I see no problem in using Super+P to open it.
But, I still have no image. Do you think I should ask for help on another forum for more specific help (because xrandr can't detect the external screen) or maybe you have a guess of what the problem may be?

Offline

#4 2020-01-07 15:55:23

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,378

Re: Plugging HDMI cable on laptop spams Display window and doesn't work

If xrandr can't detect the display, then xfce4-settings won't either - it uses libxrandr. You need to find out why xrandr isn't working.

Offline

#5 2020-01-07 18:54:49

gnx
Member
Registered: 2020-01-06
Posts: 3

Re: Plugging HDMI cable on laptop spams Display window and doesn't work

Thanks for the help.
I had this xrandr problem for months and I was giving up. It's not how it should be but I found a solution here https://lists.freedesktop.org/archives/ … 01565.html
You need to use the parameter video=HDMI-0 (At least for me)

Offline

Board footer

Powered by FluxBB