Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-02-12 18:33:16

Maurycy88
Member
Registered: 2020-02-12
Posts: 4

Xfce4.14 - partially working autohide delay.

Hi there,

I have a little problem with panels autohide delay. I have in ~/.config/gtk-3.0/gtk.css

* {
-XfcePanelWindow-popup-delay: 400;
-XfcePanelWindow-popdown-delay: 2500;
}

And the sad fact is that the first part is working, so popup of panels is delayed, but they are diseapring instantly. For me the second part is trully important. I would be appreciate for help. sad

Offline

#2 2020-02-12 20:16:19

Aravisian
Member
Registered: 2019-08-17
Posts: 406

Re: Xfce4.14 - partially working autohide delay.

I am not sing XFCE Desktop at this time (testing Cinnamon) but later today when I have time, I can try testing some ideas but in the meantime, I would suspect that the popup delay is not working, either. I could be wrong. But if in your .css is another command enabling that, it would give the illusion that it is working because it is working under another instruction.
You might try

-#define DEFAULT_POPUP_DELAY   (400)
-#define DEFAULT_POPDOWN_DELAY (2500)

Or.

XfcePanelWindow-popup {
      transition-delay: all 400ms;
}
XfcePanelWindow-popdown {
      transition-delay: all 2500ms;
}

I do not know if either of the above will work. I cannot test it to play with it at this moment- But I figure some answer is better than waiting and a wrong answer that nudges you in the right direction to figure it out is still helpful.

Offline

#3 2020-02-12 22:55:54

alcornoqui
Member
Registered: 2014-07-28
Posts: 763

Re: Xfce4.14 - partially working autohide delay.

Offline

#4 2020-02-12 23:37:33

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,124

Re: Xfce4.14 - partially working autohide delay.

Try the following instead:

#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 2500;
}

Tested to work successfully in my Debian Sid VM.

Offline

#5 2020-02-13 17:21:38

Maurycy88
Member
Registered: 2020-02-12
Posts: 4

Re: Xfce4.14 - partially working autohide delay.

-#define DEFAULT_POPUP_DELAY   (400)
-#define DEFAULT_POPDOWN_DELAY (2500)

This one killed my panels. All panels disappeared after "xfce4-panel -r". sad

XfcePanelWindow-popup {
      transition-delay: all 400ms;
}
XfcePanelWindow-popdown {
      transition-delay: all 2500ms;
}

Doesn't work either. sad

#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 2500;
}

This one works exactly like mine. 1st part looks like working, second part nope. sad

@alcornoqui
I don't know what to do with information from first url. I read the second one before i wrote 1st post, but still i have no idea how to make it working. sad

Offline

#6 2020-02-13 17:26:16

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,124

Re: Xfce4.14 - partially working autohide delay.

Maurycy88 wrote:
#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 2500;
}

This one works exactly like mine. 1st part looks like working, second part nope. sad

Which distro and which version of xfce4-panel are you running?

Offline

#7 2020-02-13 18:16:27

Maurycy88
Member
Registered: 2020-02-12
Posts: 4

Re: Xfce4.14 - partially working autohide delay.

ToZ wrote:
Maurycy88 wrote:
#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 2500;
}

This one works exactly like mine. 1st part looks like working, second part nope. sad

Which distro and which version of xfce4-panel are you running?

Xubuntu 18.04 with Xfce4.14. I made it with netinstall ubuntu (system core without any de) then added repository xubuntu-dev/staging, then installed xubuntu-core.

Offline

#8 2020-02-13 23:11:33

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,124

Re: Xfce4.14 - partially working autohide delay.

Which exact version of xfce4-panel are you running?

xfce4-panel -V

Is there anything else in your ~/.config/gtk-3.0/gtk.css file? Can you post the full content? Or alternatively, leave only the above in the file for a test. (Note: you need to restart xfce-panel for changes to gtk.css to have an effect)

Offline

#9 2020-02-14 03:21:57

Maurycy88
Member
Registered: 2020-02-12
Posts: 4

Re: Xfce4.14 - partially working autohide delay.

ToZ wrote:

Which exact version of xfce4-panel are you running?

xfce4-panel -V

Is there anything else in your ~/.config/gtk-3.0/gtk.css file? Can you post the full content? Or alternatively, leave only the above in the file for a test. (Note: you need to restart xfce-panel for changes to gtk.css to have an effect)

xfce4-panel 4.14.3 (Xfce 4.14)

Copyright (c) 2004-2011
	The Xfce development team. All rights reserved.

Please report bugs to <http://bugzilla.xfce.org/>.

I created gtk.css, there're only there 4 lines from the 1st post.

As i wrote i use "xfce4-panel -r" after every change in gtk.css.

Offline

#10 2020-11-14 13:59:45

hamdibe
Member
Registered: 2020-11-14
Posts: 1

Re: Xfce4.14 - partially working autohide delay.

Had this same problem, for me the fix was to right-click the panel -> Panel -> Panel preferences -> and set "Automatically hide the panel" to Always. Then the configuration in gtk.css should work.

Offline

Board footer

Powered by FluxBB