Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-03-08 06:32:20

lancsuk
Member
Registered: 2020-03-08
Posts: 2

[ SOLVED ] xfce4-panel-4.14.3 on slackware current failed

Hiya,

recently I've tried to build xfce4-panel-4.14.3 on Slackware current.

/usr/include/glib-2.0/gobject/gtype.h:679:1: note: declared here
  679 | {
      | ^
In file included from /usr/include/gtk-2.0/gtk/gtktoolitem.h:31,
                 from /usr/include/gtk-2.0/gtk/gtktoolbutton.h:30,
                 from /usr/include/gtk-2.0/gtk/gtkmenutoolbutton.h:30,
                 from /usr/include/gtk-2.0/gtk/gtk.h:126,
                 from xfce-panel-image.c:30:
/usr/include/gtk-2.0/gtk/gtktooltips.h:73:3: warning: ‘GTimeVal’ is deprecated: Use 'GDateTime' instead [-Wdeprecated-declarations]
   73 |   GTimeVal last_popdown;
      |   ^~~~~~~~
In file included from /usr/include/glib-2.0/glib/galloca.h:32,
                 from /usr/include/glib-2.0/glib.h:30,
                 from /usr/include/glib-2.0/gobject/gbinding.h:28,
                 from /usr/include/glib-2.0/glib-object.h:22,
                 from /usr/include/glib-2.0/gio/gioenums.h:28,
                 from /usr/include/glib-2.0/gio/giotypes.h:28,
                 from /usr/include/glib-2.0/gio/gio.h:26,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
                 from /usr/include/gtk-2.0/gdk/gdk.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from xfce-panel-image.c:30:
/usr/include/glib-2.0/glib/gtypes.h:547:8: note: declared here
  547 | struct _GTimeVal
      |        ^~~~~~~~~
  CCLD     libxfce4panel-1.0.la
  GISCAN   libxfce4panel-2.0.gir
xfce-panel-macros-46.h:55: Warning: libxfce4panel: symbol='panel_slice_alloc': Unknown namespace for symbol 'panel_slice_alloc'
xfce-panel-macros-46.h:68: Warning: libxfce4panel: symbol='panel_slice_alloc0': Unknown namespace for symbol 'panel_slice_alloc0'
xfce-panel-macros-46.h:80: Warning: libxfce4panel: symbol='panel_slice_free1': Unknown namespace for symbol 'panel_slice_free1'
xfce-panel-macros-46.h:93: Warning: libxfce4panel: symbol='panel_slice_new': Unknown namespace for symbol 'panel_slice_new'
xfce-panel-macros-46.h:106: Warning: libxfce4panel: symbol='panel_slice_new0': Unknown namespace for symbol 'panel_slice_new0'
xfce-panel-macros-46.h:118: Warning: libxfce4panel: symbol='panel_slice_free': Unknown namespace for symbol 'panel_slice_free'
xfce-panel-macros-46.h:131: Warning: libxfce4panel: symbol='PANEL_PARAM_READABLE': Unknown namespace for symbol 'PANEL_PARAM_READABLE'
xfce-panel-macros-46.h:142: Warning: libxfce4panel: symbol='PANEL_PARAM_WRITABLE': Unknown namespace for symbol 'PANEL_PARAM_WRITABLE'
xfce-panel-macros-46.h:153: Warning: libxfce4panel: symbol='PANEL_PARAM_READWRITE': Unknown namespace for symbol 'PANEL_PARAM_READWRITE'
  GICOMP   libxfce4panel-2.0.gir
 VAPIGEN libxfce4panel-2.0.vapi
warning: empty metadata
libxfce4panel-2.0.gir:2359.7-2359.40: error: overriding method `Xfce.PanelPlugin.remote_event' is incompatible with base method `bool Xfce.PanelPluginProvider.remote_event (string, GLib.Value, uint)': too few parameters.
make[3]: *** [/usr/share/vala/Makefile.vapigen:61: libxfce4panel-2.0.vapi] Error 1
make[3]: Leaving directory '/home/lancs/build/xfce/xfce4-panel-4.14.3/libxfce4panel'
make[2]: *** [Makefile:891: all] Error 2
make[2]: Leaving directory '/home/lancs/build/xfce/xfce4-panel-4.14.3/libxfce4panel'
make[1]: *** [Makefile:612: all-recursive] Error 1
make[1]: Leaving directory '/home/lancs/build/xfce/xfce4-panel-4.14.3'
make: *** [Makefile:523: all] Error 2

How i can fix this issue?

System:

OS   Slackware current
Kernel: 5.4.24
Gtk+3  3.24.14
GCC    9.2.0

in order built
libxfce4util   4.14.0 done
xfconf         4.14.1 done
libxfce4ui    4.14.1 done
Exo            0.12.1 done
Garcon       0.6.4 done
xfce4-panel 4.14.3 failed


lancs

Last edited by lancsuk (2020-03-09 08:08:47)

Offline

#2 2020-03-08 11:47:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,381

Re: [ SOLVED ] xfce4-panel-4.14.3 on slackware current failed

Hello and welcome.

Which version of vala? I'm getting the same error with vala 0.48.0. Downgrading to 0.46.6, re-running autogen/configure and building makes it work again.

See this bug report.

Offline

#3 2020-03-09 08:13:04

lancsuk
Member
Registered: 2020-03-08
Posts: 2

Re: [ SOLVED ] xfce4-panel-4.14.3 on slackware current failed

ToZ wrote:

Hello and welcome.

Which version of vala? I'm getting the same error with vala 0.48.0. Downgrading to 0.46.6, re-running autogen/configure and building makes it work again.

See this bug report.

Indeed 0.48.0, I've downgraded to 0.46.6.

thanks a lot

Last edited by lancsuk (2020-03-11 05:09:21)

Offline

Board footer

Powered by FluxBB