Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-05-13 21:07:50

Danwe
Member
Registered: 2020-05-13
Posts: 4

[Solved]Switching desktop toggles desktop when already on that desktop

Hi! I am using latest Manjaro with Xfce 4.14. Lately the switching desktop (I use Alt+1|2|3|4) behavior has changed for me.
Previously, when pressing Alt+1 while already on Desktop 1, nothing would happen. With the new behavior the system switches back to the previous desktop.

E.g.:

  1. Alt+2 to navigate to desktop 2

  2. Alt+1 to navigate to desktop 1

  3. Alt+1 again

Result: Navigates back to desktop 2
Expected: Should just stay on desktop 1

The behavior is pretty annoying, not sure whether it's a new feature or whether I've accidentally changed some setting. I was recently playing with my sidebar panel and changed the "Workspace switcher" widget's settings. But I can't see any settings there nor in the "Workspace settings" that seem relevant at all.

Thanks for any help!

Last edited by Danwe (2020-05-13 22:22:56)

Offline

#2 2020-05-13 21:27:24

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,574

Re: [Solved]Switching desktop toggles desktop when already on that desktop

Hello and welcome.

Can we see your current window manager keyboard shortcuts?

xfconf-query -c xfce4-keyboard-shortcuts -lv | grep xfwm4

How many workspaces do you use?

It might be that you are using the previous and next workspace shortcuts and have workspace cycling enabled (Window Manager Tweaks > Workspaces).

Offline

#3 2020-05-13 21:38:58

Danwe
Member
Registered: 2020-05-13
Posts: 4

Re: [Solved]Switching desktop toggles desktop when already on that desktop

Thank you ToZ!

I indeed had workspace cycling enabled in the Window Manager Tweaks enabled. I remember having done some changes there to try things out and probably forgot to disable that again. It's always a bit irritating to have these settings in all kind of places and menus. Thanks for pointing it out.

Offline

#4 2020-05-13 21:45:51

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 138

Re: [Solved]Switching desktop toggles desktop when already on that desktop

That's odd behaviour, your previous set up I mean. ALT+1,2,3 switches tabs in Firefox. On a non FF work space it does nothing. To switch workspaces it's always been CTL+ALT and arrow left or right(<>).

Offline

#5 2020-05-13 21:54:26

Danwe
Member
Registered: 2020-05-13
Posts: 4

Re: [Solved]Switching desktop toggles desktop when already on that desktop

I've configured it that way, ALT+1 switches to workspace 1. I switch workspaces A LOT so I wanted to press 2 keys max (so no CTRL+ALT). Also, in my browser I use Ctrl+Tab / Ctrl+Shift+Tab to toggle to the next/previous tab (plus I use multiple browsers and instances of them on different workspaces, so you get the idea). ALT+Arrow is the most unpractical of all since it requires two hands, which is an absolute no-go.

I think my first choice would have been MOD+1|2|3|4 but I believe that wasn't working well when I started using Xfce around two years ago (could be wrong though).

Last edited by Danwe (2020-05-13 21:55:29)

Offline

Board footer

Powered by FluxBB