Xfce Forum

Sub domains

You are not logged in.

#1 2020-05-31 19:42:33

From: right by Jesus, our Saviour
Registered: 2013-06-15
Posts: 511

xfce4-terminal unexplained differences

under multiple userids i run xfce4-terminal with a font size of 17 and a geometry of 138x38.  those numbers are what is specified.  the actual geometry is usually different over a wide range of specified geometry values.  a small few get the actual specified values.  if the specified values are way too large to fit the display size, the actual geometry is smaller.  that's to be expected.  but smaller specifications, in most cases, are 1 less than what is specified.  that could be due to rounding errors, especially in floating point parts, in the calculations done to figure out what can fit. it may be dividing, multiplying back, then truncating to whole numbers, resulting in some value with .99999... becoming lost.  i don't know how it actually does this, but, i know i would not use float (even in C) and would, instead, use scaled integer.

but here is what i find especially strange.  the actual geometry comes out slightly different under one userid compared to all the other userids.  in all cases the geometry i specify is 138x38.  the font size is 17.  the display pixel size is 1920x1080.  then panel font size is 14.  i did set a theme with a narrow header, using the same theme for all userids.  the geometry the terminal uses ends up being 137x36 for all userids except the one named "forums" (uid 1015) which gets 137x37.  it gets 1 more row.  in all cases the window has no borders on the sides and bottoms.  so it is full screen except for the top, where i can still see the panel.  i can flip back and forth between "forums" and "skaperen" and all the characters are in the same pixel position, except for the 37th row which is blank for all users but filled in for user "forums".

i have looked around and tried tweaking many settings to see what can affect this and might be different for "forums" but so far have found nothing.  can anyone suggest what might be different that could do this that i might have missed?  are screenshots needed?

this is Xfce4 4.12.2 under Xubuntu 18.04 LTS.

Last edited by Skaperen (2020-05-31 19:44:49)


Board footer

Powered by FluxBB