Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-06-25 03:49:30

vinox14
Member
Registered: 2020-05-25
Posts: 5

Thumbnail in Thunar as root

Hello!!! So I installed Xfce arch using zen installer, everything is working fine except I noticed that when I'm using "thunar in root" mode thumbnails doesn't show up.
Is there some configuration or setting I need to enable?

Offline

#2 2020-06-25 11:16:14

eriefisher
Member
From: ON, Canada
Registered: 2008-10-25
Posts: 220

Re: Thumbnail in Thunar as root

It should be automatic. Is tumberd running?


Siduction
Debian Sid
Xfce 4.14

Offline

#3 2020-06-25 12:44:53

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,710

Re: Thumbnail in Thunar as root

Automatic X11 dbus spawning was disabled in Arch linux a while back as a security precaution, and this prevents tumblerd from automatically starting in root mode when root thunar is initiated. If you try to run "pkexec thunar" in a terminal window on Arch you should see something like:

ThunarThumbnailer: failed to create proxy: Error spawning command line “dbus-launch --autolaunch=78411821b9964bb583290cc4c33a07f3 --binary-syntax --close-stderr”: Child process exited with code 1

The way to work around this is to manually create a one time dbus connection using "dbus-run-session". This seems to work easiest with gksu (from the AUR) and a command like:

gksu dbus-run-session thunar

Make sure that your thunar root custom action uses this command.

Online

#4 2020-07-04 00:32:06

vinox14
Member
Registered: 2020-05-25
Posts: 5

Re: Thumbnail in Thunar as root

ToZ wrote:

Automatic X11 dbus spawning was disabled in Arch linux a while back as a security precaution, and this prevents tumblerd from automatically starting in root mode when root thunar is initiated. If you try to run "pkexec thunar" in a terminal window on Arch you should see something like:

ThunarThumbnailer: failed to create proxy: Error spawning command line “dbus-launch --autolaunch=78411821b9964bb583290cc4c33a07f3 --binary-syntax --close-stderr”: Child process exited with code 1

The way to work around this is to manually create a one time dbus connection using "dbus-run-session". This seems to work easiest with gksu (from the AUR) and a command like:

gksu dbus-run-session thunar

Make sure that your thunar root custom action uses this command.


thank you very much!!!

Offline

Board footer

Powered by FluxBB