Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-06-25 08:37:14

ArrayIndexOutOfBounds
Member
Registered: 2020-06-19
Posts: 6

Window Manager not starting correctly

Hi everyone:

My desktop froze the other day suddenly, and I rebooted the PC manually. From that point on, every time I start my PC, all the windows that where on the screen when it froze are loaded automatically, and xfwm4 does not launch on background as it is expected to do.

This is what my desktop looks like:

Screenshot-2020-06-25-10-28-09.png

As you can see, there are no window frames and it looks horrible.

Help is very much appreciated, thank you beforehand smile

Offline

#2 2020-06-25 11:11:32

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,985

Re: Window Manager not starting correctly

Try clearing your sessions cache. The best way to do it is to delete the contents of ~/.cache/sessions when not logged in. A second way is to clear it via the "Clear Sessions" button in Settings Manager > Session and Startup > Session. If you do it this way, when logging out and back in again, make sure that "Save session" is not enabled.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2020-06-25 11:38:50

ArrayIndexOutOfBounds
Member
Registered: 2020-06-19
Posts: 6

Re: Window Manager not starting correctly

ToZ wrote:

Try clearing your sessions cache. The best way to do it is to delete the contents of ~/.cache/sessions when not logged in. A second way is to clear it via the "Clear Sessions" button in Settings Manager > Session and Startup > Session. If you do it this way, when logging out and back in again, make sure that "Save session" is not enabled.

Thank you so much, absolutely worked!

Offline

#4 2024-02-19 16:53:41

xfu
Member
Registered: 2022-03-18
Posts: 6

Re: Window Manager not starting correctly

ToZ wrote:

Try clearing your sessions cache. The best way to do it is to delete the contents of ~/.cache/sessions when not logged in. A second way is to clear it via the "Clear Sessions" button in Settings Manager > Session and Startup > Session. If you do it this way, when logging out and back in again, make sure that "Save session" is not enabled.

This also worked for me after restarting and being unable to launch Window Manager, thank you!

Offline

Board footer

Powered by FluxBB