Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-07-15 11:55:12

gena2x
Member
Registered: 2020-05-01
Posts: 9

sound volume regulation problem

I am using debian version of xfce4 and '/usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/libpulseaudio-plugin.so 4 18874375 pulseaudio PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system' v 0.4.3 to regulate the volume.
Eventually everything works, but in 50% of time it 'hungs'.
What happens is that if I click on volume it hangs for 1 minute or something like that, and after one minute it shows popup with list of volumes.

This is not something what started recently, it persists at least over last few years.

Is there a way to debug? I guess I could do coredump while it is hung? Some logs?

And may be related may be not:
Sometimes something like that happens with whole UI. I.e. everything seems to be working, but I can not input anything with mouse or keyboard, while both clearly works (i can switch with ctrl-alt-1 to terminal and back), I can kill X11 with ctrl-alt-backspace. But this is really rarely.

Any tips on debugging this?

May be both related to my buggy bluetooth headphones, but I can not see any clear pattern how for now.

Thanks,
Gennady

Offline

#2 2020-07-16 02:59:01

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,865

Re: sound volume regulation problem

Does anything show up on your ~/.xsession-errors log file? Can you post the contents of said file on fresh login and again after the hang?

Offline

#3 2020-07-16 12:42:27

gena2x
Member
Registered: 2020-05-01
Posts: 9

Re: sound volume regulation problem

Ok, so it goes to that file. So first I was able to reproduce it reliably - if I connected bluetooth headphones it works fine, but if I click output device selection in the popup, it hangs.
Full log: https://pastebin.com/9pRqnYKX

This two messages printed after hung:
(wrapper-2.0:6468): pulseaudio-plugin-WARNING **: 15:27:51.437: Error while sending notification : Error calling StartServiceByName for org.freedesktop.Notifications: Timeout was reached


(wrapper-2.0:6468): pulseaudio-plugin-WARNING **: 15:28:26.754: Error while sending notification : Error calling StartServiceByName for org.freedesktop.Notifications: Process org.freedesktop.Notifications exited with status 1

After few switches it completely hung now. So volume button remains pressed for the last few minutes and do not react on clicks.

Pavucontrol works fine, I can launch it manually and switch anything there.

I attached to process with debugger, but there is nothing interesting, all threads waiting on poll:
https://pastebin.com/Qy9agVzA

Offline

#4 2020-07-16 14:58:04

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,865

Re: sound volume regulation problem

(wrapper-2.0:6468): libnotify-WARNING **: 15:16:48.341: Failed to connect to proxy

...and:

(wrapper-2.0:6468): pulseaudio-plugin-WARNING **: 15:25:50.765: Error while sending notification : Error calling StartServiceByName for org.freedesktop.Notifications: Process org.freedesktop.Notifications exited with status 1

There is a problem with the notification daemon. Which one is running on your system? I noticed stubs of KDE programs in your ~/.xsession-errors and wonder if there is a conflict.

ps -ef | grep notif

...and also, what happens if you manually trigger a notification:

notify-send test test

And finally, how do you start Xfce? Via a display manager (if so, which one) or manually (if so, how and what is content of your ~/.xinitrc file)?

Offline

#5 2020-07-16 21:25:09

gena2x
Member
Registered: 2020-05-01
Posts: 9

Re: sound volume regulation problem

Oh, nice, I got the idea! yeah, notify-send did not work indeed.

I looked into it, (checked how my dm, lxdm, etc) - and suddenly while reading description found that here https://wiki.archlinux.org/index.php/De … leshooting

there is a description of exactly my case, even with volume hanging! I think I installed kde-full in the past to see how modern kde looks like and it remained. The xcfe4-notifyd and plasma-workspace should probably conflict with each other. And it is funny same problem appears in completely different distros. I wonder if I should file bug report somewhere or may be patch some debian/control?

And now brightness controls working well as well.

Last edited by gena2x (2020-07-16 21:34:29)

Offline

#6 2020-07-16 21:31:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,865

Re: sound volume regulation problem

Actually, it was reported (https://gitlab.xfce.org/apps/xfce4-noti … 3f434a6f47) and has been fixed in the git tree. The fix will be available in the next release of xfce4-notifyd.

Offline

#7 2020-07-16 21:37:18

gena2x
Member
Registered: 2020-05-01
Posts: 9

Re: sound volume regulation problem

Nice, so nobody will suffer from this problem anymore - good.

Offline

Board footer

Powered by FluxBB