Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-07-20 21:30:39

NuncEstBibendum
Member
Registered: 2017-10-13
Posts: 13

xfce4-terminal font size change

I am using XFCE 4.12 under Linux. My main terminal emulator is xfce4-terminal. When I want to change the size of the font in a given instance of xfce4-terminal, I just have to elicit the terminal's menu and then, with Preferences -> Appearance, change the font size as needed. The problem with this is that the change is applied to all the xfce4-terminal instances that I may have open at the time.

    Is it possible to change the size of the font of an xfce4-terminal instance, while leaving all other instances untouched?

Offline

#2 2020-07-20 23:07:07

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,124

Re: xfce4-terminal font size change

Does the "--disable-server" parameter work for you? I don't recall when it stopped working.

If it doesn't work, another option is to specify a different XDG_CONFIG_HOME like this:

env XDG_CONFIG_HOME=/home/user_name/.config2 xfce4-terminal --disable-server

...it will create a ~/.config2 directory where it will save the preferences for that instance.

Offline

#3 2020-07-20 23:35:43

NuncEstBibendum
Member
Registered: 2017-10-13
Posts: 13

Re: xfce4-terminal font size change

Thanks for your feedback. --disable-server on its own does not solve the problem. The XDG_CONFIG_HOME approach does, but I guess I would have to come up with a small wrapper script to turn it into something I can practically use. It doesn't sound too difficult, the trickiest bit probably being how to make sure that I don't end up with lots of unused .config* files. Nevertheless, that was a good lead - thanks.

Offline

#4 2020-07-20 23:44:54

alcornoqui
Member
Registered: 2014-07-28
Posts: 763

Re: xfce4-terminal font size change

The option --disable-server works for me in Xubntu 18.04 with Xfce 4.14, is it not expected to work?

Offline

#5 2020-07-21 00:26:29

NuncEstBibendum
Member
Registered: 2017-10-13
Posts: 13

Re: xfce4-terminal font size change

It doesn't in Xfce 4.12, at least not in mine (Slackware 14.2.) Anyway, the script to invoke to get things to work as I want is very straightforward:

#! /bin/sh

GENERIC_CONF=$HOME/.config/xfce4/terminal/terminalrc
CONF_ROOT=$HOME/.term-config
mkdir $CONF_ROOT 2> /dev/null
CONF_DIR=`mktemp -d $CONF_ROOT/config.XXXXXX`
mkdir -p $CONF_DIR/xfce4/terminal
cp $GENERIC_CONF $CONF_DIR/xfce4/terminal
env XDG_CONFIG_HOME=$CONF_DIR xfce4-terminal --disable-server
rm -rf $CONF_DIR

Offline

#6 2020-07-21 00:55:08

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,124

Re: xfce4-terminal font size change

alcornoqui wrote:

The option --disable-server works for me in Xubntu 18.04 with Xfce 4.14, is it not expected to work?

What version of xfce4-terminal is installed. It doesn't work in the git version of xfce4-terminal any more. There are some bug reports about it.

Offline

#7 2020-07-21 07:06:20

alcornoqui
Member
Registered: 2014-07-28
Posts: 763

Re: xfce4-terminal font size change

ToZ wrote:

What version of xfce4-terminal is installed. It doesn't work in the git version of xfce4-terminal any more. There are some bug reports about it.

xfce4-terminal 0.8.7.4 (Xfce 4.14)

Offline

Board footer

Powered by FluxBB