Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-01-04 17:59:01

File Manager
Member
Registered: 2019-11-01
Posts: 27

StartupNotify problems in Xfce

As a long time Gnome 2/MATE user I never thought about the StartupNotify key. It worked more or less like in Windows. The cursor would spin until the application was loaded and then stop.

When I switched to Xfce the same StartupNotify key would result in an archaic experience. So I disabled this key for all applications, which can be easily done from for example Whisker menu.

When I say archaic experience I mean that the cursor starts spinning just like in MATE, but it doesn't stop when the application has loaded. It keeps spinning for what feels like an eternity, but could be an additional 30 seconds. To a Windows or MATE user this gives the impression that the computer is "thinking", but in reality the application has already loaded and no activity is taking place and yet the cursor continues to spin in Xfce.

This is easy to observe by launching an application with the StartupNotify key set to true.

I tested with MX 19.3 (Debian Buster) in VirtualBox with Xfce 4.14 and MATE 1.20. I launched Firefox (build done by Mozilla and packaged by MX) and measured for how long the cursor would spin. I think any distro and application could be used and the same difference would be observed.

Average result in MATE (cursor positioned on panel or on window decoration): 15 - 20 seconds
Average result in Xfce (cursor positioned on panel or on window decoration): 30 - 60 seconds

Offline

#2 2021-01-04 18:13:53

MrEen
Member
Registered: 2019-04-19
Posts: 263

Re: StartupNotify problems in Xfce

Just to be clear, you're referring to StartupNotify=true in .desktop files, correct?

I'm on an old version of Mint and just started 5 different apps that have that set and they all fired up quickly and the spinner stopped as soon as they were open.

Do you have file-roller.desktop (Name=Archive Manager) in MX? If so, do you get the same when opening that? I wouldn't want to test with browsers as there are so many things with those that might cause this.

Offline

#3 2021-01-04 18:27:25

File Manager
Member
Registered: 2019-11-01
Posts: 27

Re: StartupNotify problems in Xfce

MrEen wrote:

Just to be clear, you're referring to StartupNotify=true in .desktop files, correct?

Yes.

MrEen wrote:

Do you have file-roller.desktop (Name=Archive Manager) in MX? If so, do you get the same when opening that? I wouldn't want to test with browsers as there are so many things with those that might cause this.

Archive Manager works as expected. The cursor stops spinning as soon as the application is ready.

The problem is that you can have StartupNotify set to true for all applications in MATE and it won't bother you. In Xfce you need to set StartupNotify to false or it will get on your nerves sooner or later.

In Xfce StartupNotify is annoying, in MATE it isn't.
It probably depends on which applications you use. I don't use any Gnome applications (not even Archive Manager) and those might be the only ones that work correctly in Xfce.

Offline

#4 2021-01-04 20:19:59

MrEen
Member
Registered: 2019-04-19
Posts: 263

Re: StartupNotify problems in Xfce

Well, for me Brave Browser has that set and I get the spinner stopping there once it's loaded. The only app where I've ever noticed it is Synaptic Package Manager as that do stuff in the background longer than anything else I use, but once the window refreshes with the appropriate parts no longer grayed out, the spinner stops there as well.

Hopefully someone else will have some ideas.

EDIT: Just noticed SPM doesn't have StartupNotify set, it's just my slowest loader.

Last edited by MrEen (2021-01-04 20:26:26)

Offline

#5 2021-01-04 21:57:23

File Manager
Member
Registered: 2019-11-01
Posts: 27

Re: StartupNotify problems in Xfce

OK, maybe more applications work well than I originally thought (because I had turned off all startup notifications and this might have been a bigger problem in Xfce 4.12 when launching GTK3 applications) so I will try to make a random list:

Work well in Xfce:
Google Chrome
Brave
Linux Mint Image Viewer (xviewer)
Xfce Terminal
Caja File Manager
Xfce Settings Manager
Featherpad text editor
Thunar File Manager
Engrampa Archive Manager
dconf Editor

Don't work well in Xfce:
Firefox
Pale Moon
MX Package Installer (Qt5 root)
MX Cleanup (Qt5 root)
Synaptic (root)
VLC Media Player
Xpad note application (GTK 3)
Simplenote Electron

The bottom line is that those applications that don't work well are much more noticeable in Xfce than in MATE.
Xpad starts in a second and spins for 30 seconds for example and 30 seconds is basically the minimum time for an application that doesn't work well in Xfce.

Offline

#6 2021-01-04 22:44:13

MrEen
Member
Registered: 2019-04-19
Posts: 263

Re: StartupNotify problems in Xfce

Yeah, I'm at a loss. Xpad worked fine for me, but I suspect my older system (Mint 18.3) makes this more of an apples to oranges thing.

Offline

#7 2021-01-04 23:21:24

File Manager
Member
Registered: 2019-11-01
Posts: 27

Re: StartupNotify problems in Xfce

MrEen wrote:

Yeah, I'm at a loss. Xpad worked fine for me, but I suspect my older system (Mint 18.3) makes this more of an apples to oranges thing.

Did you make sure that Xpad had StartupNotify set to true? This can also be done from Whisker menu. Right click application > Edit Application > check Use startup notification > Save.

Then launch Xpad. Xpad is one of those applications that I would assume to be problematic despite being GTK3.

Offline

#8 2021-01-04 23:24:40

MrEen
Member
Registered: 2019-04-19
Posts: 263

Re: StartupNotify problems in Xfce

Yes, I checked it before launching it.

In case it matters at all, the xenial version of Xpad that I have is 4.5.0-0ubuntu1 which is also pretty old.

Offline

#9 2021-01-04 23:42:00

File Manager
Member
Registered: 2019-11-01
Posts: 27

Re: StartupNotify problems in Xfce

I actually have an Ubuntu version of Xpad in Debian Buster, because the Buster version was broken.

Anyway, there should be enough problematic applications for any Xfce user unless they do what I did and simply set StartupNotify to false.

This isn't a new problem in Xfce; from 2014:

This is driving me CRAZY!

I don't even know where to post about it, but I think it could be solved at the xfce desktop level.
I am using xfce window manager and panels along with cairo dock, but I use a variety of
applications in this environment.

In particular I use dolphin and gwenview to look through files and then
launch programs on those documents, videos, images, etc.

For many of the launchings, a busy cursor is put up for thirty seconds,
even though the program is launched with a tiny fraction of a second and
in fact I may have gone on to other programs.

https://forum.xfce.org/viewtopic.php?id=8728

Offline

Board footer

Powered by FluxBB