Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-01-22 10:06:35

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

[SOLVED] Timed hiding of the panel

Recently, the menu bar takes three seconds before disappearing.
It seems to me that auto-masking was instantaneous until then ...

Is it possible to remove this delay somewhere?

Thank you in advance to the person who could help me.

jp willm
https://willms.pagesperso-orange.fr/
https://www.youtube.com/channel/UCJwHW5 … 16cxUoBOUw

Last edited by jp willm (2021-01-23 12:24:25)

Offline

#2 2021-01-22 23:49:53

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [SOLVED] Timed hiding of the panel

Which menu are you referring to?
Also, which version of Xfce are you running?

Offline

#3 2021-01-23 00:19:15

MrEen
Member
Registered: 2019-04-19
Posts: 295

Re: [SOLVED] Timed hiding of the panel

I think the OP is referring to the Panel. And I suspect Automatically hide the panel may have been changed from Always to Intelligently in the Panel Preferences. I don't use those, so it's just a guess.

Offline

#4 2021-01-23 04:47:29

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

Re: [SOLVED] Timed hiding of the panel

ToZ wrote:

Which menu are you referring to?
Also, which version of Xfce are you running?

Oops sorry I meant "panels" :-/

I have XFCE4 (4.16.0-1) and Xfwm4 (4.16.1-1) under Artix Linux openrc.
I am using three panels.

In the "Pannel Preferences", for "Automatically hide panel" 2 and 3, I chose "Never".

When I hover the mouse over panel 2 or 3 it appears. But when I move the cursor away, the panel doesn't disappear right away; it remains visible for two to three seconds, which is often annoying.

I looked for a possible configuration file to remove this delay, but couldn't find one.

jp-artix:[jp]:~$ neofetch
                   '                      jp@jp-artix
                  'o'                     -----------
                 'ooo'                    OS: Artix Linux x86_64
                'ooxoo'                   Host: Aspire ES1-732 V1.18
               'ooxxxoo'                  Kernel: 5.10.8-artix1-1
              'oookkxxoo'                 Uptime: 1 hour
             'oiioxkkxxoo'                Packages: 1140 (pacman)
            ':;:iiiioxxxoo'               Shell: bash 5.1.4
               `'.;::ioxxoo'              Resolution: 1600x900
          '-.      `':;jiooo'             DE: Xfce
         'oooio-..     `'i:io'            WM: Xfwm4
        'ooooxxxxoio:,.   `'-;'           WM Theme: Daloa
       'ooooxxxxxkkxoooIi:-.  `'          Theme: Adwaita [GTK2], Artix-dark [GT
      'ooooxxxxxkkkkxoiiiiiji'            Icons: oxygen [GTK2], breeze [GTK3]
     'ooooxxxxxkxxoiiii:'`     .i'        Terminal: xfce4-terminal
    'ooooxxxxxoi:::'`       .;ioxo'       Terminal Font: Monospace 12
   'ooooxooi::'`         .:iiixkxxo'      CPU: Intel Pentium N4200 (4) @ 2.500G
  'ooooi:'`                `'';ioxxo'     GPU: Intel Celeron N3350/Pentium N420
'i:'`                          '':io'    Memory: 1643MiB / 3753MiB

Offline

#5 2021-01-23 05:09:38

MrEen
Member
Registered: 2019-04-19
Posts: 295

Re: [SOLVED] Timed hiding of the panel

Haha, I'm now thoroughly confused. I would have thought Never would prevent them from hiding ever.

Have you tried setting to Always or Intelligently to see if there's a difference?

Maybe I'm barking up the wrong tree here.

Offline

#6 2021-01-23 06:25:52

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

Re: [SOLVED] Timed hiding of the panel

MrEen wrote:

Haha, I'm now thoroughly confused. I would have thought Never would prevent them from hiding ever.

Still sorry, it's "Always" that I meant (I'm French).

Have you tried setting to Always or Intelligently to see if there's a difference?

Indeed, the "Intelligently" mode has a shorter persistence time and I will use it while waiting to know how to remove the persistence time from the "Always" mode.

Thank you !

Offline

#7 2021-01-23 11:40:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [SOLVED] Timed hiding of the panel

You can set popup and popdown delay values. Put the following in ~/.config/gtk-3.0/gtk.css (and restart the panel "xfce4-panel -r" for it to take effect):

#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 2500;
}

...the lower the values the less the delay.

Offline

#8 2021-01-23 11:56:23

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

Re: [SOLVED] Timed hiding of the panel

ToZ wrote:

You can set popup and popdown delay values. Put the following in ~/.config/gtk-3.0/gtk.css (and restart the panel "xfce4-panel -r" for it to take effect):

#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 2500;
}

...the lower the values the less the delay.

Ah, it's magic 8-)
It's like the color of DateTime.
Thank you so much !

Offline

#9 2021-03-30 18:49:50

tankist02
Member
Registered: 2021-03-30
Posts: 2

Re: [SOLVED] Timed hiding of the panel

Tried that solution, did not help:

$ cat .config/gtk-3.0/gtk.css
#XfcePanelWindow {
   -XfcePanelWindow-popup-delay: 400;
   -XfcePanelWindow-popdown-delay: 400;
}

and logged out / logged in back. The popdown action is still delayed too much for my taste.

What am I doing wrong? BTW I'm on XFCE 4.16 FreeBSD 13 RC3

Offline

#10 2021-03-30 19:23:59

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

Re: [SOLVED] Timed hiding of the panel

I put :
#XfcePanelWindow {
    -XfcePanelWindow-popup-delay: 0;
    -XfcePanelWindow-popdown-delay: 0;
}
But there is always a little latency; as it always has been, it seems to me.

Offline

#11 2021-03-30 21:23:37

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [SOLVED] Timed hiding of the panel

Try these as well (in addition to):

xfconf-query -c xfce4-panel -p /panels/panel-2/popdown-speed -t int -s 0 --create
xfconf-query -c xfce4-panel -p /panels/panel-2/popup-speed -t int -s 0 --create

...where "panel-2" is the actual panel ID.

Offline

#12 2021-03-31 00:19:46

tankist02
Member
Registered: 2021-03-30
Posts: 2

Re: [SOLVED] Timed hiding of the panel

Hooray, it worked after I put zeros everywhere, cleared the cache:

rm -rf ~/.cache

and logged out and back in.

Thanks a lot!

Offline

#13 2021-03-31 06:15:28

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

Re: [SOLVED] Timed hiding of the panel

ToZ wrote:

Try these as well (in addition to):
.../...

With these two command lines, it's perfect. 8-)
On the other hand, I did not understand which file was modified ...

Offline

#14 2021-03-31 10:23:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,151

Re: [SOLVED] Timed hiding of the panel

jp willm wrote:

On the other hand, I did not understand which file was modified ...

An xfconf configuration file. Ultimately, it would be ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml (once the settings is saved). More info on xfconf starting here.

Offline

#15 2021-03-31 11:14:33

jp willm
Member
From: France Alsace
Registered: 2021-01-07
Posts: 11
Website

Re: [SOLVED] Timed hiding of the panel

ToZ wrote:
jp willm wrote:

On the other hand, I did not understand which file was modified ...

An xfconf configuration file. Ultimately, it would be ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml (once the settings is saved). More info on xfconf starting here.

I found and saw in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml  the line:
   

   </property>
       <property name = "popdown-speed" type = "int" value = "0" />

Thanks for link. 8-)

Offline

Board footer

Powered by FluxBB