Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-02-14 16:03:12

24CaratUncleMaterial
Member
Registered: 2021-02-14
Posts: 2

Thunar (1.6.11) search quirk?

I have had to downgrade my Debian setup to edition 9 due to a graphics card dying - the onboard graphics I'm left with are nVidia with a discontinued driver. That itself is no problem and I now have repopulated my hard drive with a nice Xfce setup. There is a minor bug that I think was dealt with but which has reappeared with the downgrade.

If I'm opening Thunar to find for example a theme's folder, I start to type Thin Ice but Thunar doesn't sit up and listen till I type the H, so it's then looking for folders beginning with an H (except when I remember and type a T twice). I've found, I think, that PCManFM was like this at one point, and a few other things, maybe when selecting a font in a couple of text editors, so perhaps it's not Thunar but a shared library issue? Or maybe it is Thunar.

Synaptic shows that Thunar doesn't have an upgrade offered and I'm wary of too much experimenting when this computer is now working so smoothly when its parts are between ten and fourteen years old.

So, a minor thing but something that I'd like to solve if possible.

Thanks for your time.

Offline

#2 2021-02-14 16:25:38

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,415

Re: Thunar (1.6.11) search quirk?

Hello and welcome.

There was an old bug in the exo package that caused this. It was fixed in exo 0.12.10.

Offline

#3 2021-02-14 18:40:22

24CaratUncleMaterial
Member
Registered: 2021-02-14
Posts: 2

Re: Thunar (1.6.11) search quirk?

Thanks. I did just naively or otherwise look into whether the working version could be installed non-destructively on my system, which it can't. If any manual little tweak can be done to bring about the same end I'd be pleased to be pointed in its direction, as I'm likely to settle with 9 for quite a while.

Offline

#4 2021-02-14 19:12:34

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,415

Re: Thunar (1.6.11) search quirk?

Unfortunately, there is no workaround that I am aware of - its a code fix (or rather a revert of a commit that caused the problem). However, the bug was introduced into 0.12.9. Can you install 0.12.8 (before the bug)? You'll lose some other fixes, but your call.

Edit: You can also patch and build your own version of a package - as an option.

Last edited by ToZ (2021-02-14 19:17:16)

Offline

Board footer

Powered by FluxBB