Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-02-16 21:12:26

r0cke+
Member
From: Mountain West, USA
Registered: 2017-10-25
Posts: 9

[solved 7-2021] Keyboard Layout not able to switch languages in Debian

I'm using Debian (testing).  I always add the Keyboard Layout to the panel, then add English US intl. with dead keys and then switch between them by clicking with the mouse between the two versions of English US.  This allows me to type in either Spanish or English, and I use each frequently.  After the update to Xfce 4.16, I can add the alternate language but cannot switch between them.  Any help would be greatly appreciated.  Thanks, in advance.

Last edited by r0cke+ (2021-07-14 16:21:02)

Offline

#2 2021-02-16 21:35:37

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,860

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

Can you have a look through the list of existing keyboard settings bugs? Is perhaps 112 the same as what you are experiencing? If so, its libklavier-related.

Offline

#3 2021-02-16 21:54:23

r0cke+
Member
From: Mountain West, USA
Registered: 2017-10-25
Posts: 9

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

I am doubtful mine is the same bug, since all was well until the last few weeks.  libxklavier is installed, and I just added gxkb and xxkb after reading your post, to no avail.

Offline

#4 2021-02-16 22:40:30

r0cke+
Member
From: Mountain West, USA
Registered: 2017-10-25
Posts: 9

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

I now can report that this problem has resolved itself!  The only thing I did was go into Keyboard Settings in the Keyboard Layout plugin and change the order of the two languages.  Upon doing that, I can switch between the two at will with the mouse on the panel as always.  I do not know what happened, but the issue is resolved for me.  Thanks.

Offline

#5 2021-07-02 02:09:51

abedholme
Member
Registered: 2021-07-02
Posts: 1

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

I too am having this issue. I have a laptop with a Brazilian Portuguese keyboard layout, and sometimes plug in another keyboard with an english language layout (especially for data entry with numbers). I type in both english and portuguese and like to be able to switch between both.  In xfce4-settings(keyboard) I can add the two layouts but there seems to be no way to toggle between them. I can delete one, or switch the order so the one I want is on top, and start up the computer again, but that very annoying.  I'm using Debian. I read through the bug reports but most of them seem to be about Ubuntu, not Debian. I read some things saying that libxklavier is deprecated. I'm not that good at this stuff....happy to go read more things and try to fix myself, but where?

Offline

#6 2021-07-02 02:31:17

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,860

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

In the Settings Manager > Keyboard > layout tab, what have you set for "Change Layout Option"? This combination should toggle between the keyboard options.

Offline

#7 2021-07-10 21:08:13

r0cke+
Member
From: Mountain West, USA
Registered: 2017-10-25
Posts: 9

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

ToZ wrote:

In the Settings Manager > Keyboard > layout tab, what have you set for "Change Layout Option"? This combination should toggle between the keyboard options.

7-10-21: Just reinstalled debian testing, and am having the same issue again.  I have messed around a lot with it, and can't get it to work.  The settings you reference are not working, no matter which shortcuts I choose.

Offline

#8 2021-07-14 16:18:20

r0cke+
Member
From: Mountain West, USA
Registered: 2017-10-25
Posts: 9

Re: [solved 7-2021] Keyboard Layout not able to switch languages in Debian

r0cke+ wrote:
ToZ wrote:

In the Settings Manager > Keyboard > layout tab, what have you set for "Change Layout Option"? This combination should toggle between the keyboard options.

7-10-21: Just reinstalled debian testing, and am having the same issue again.  I have messed around a lot with it, and can't get it to work.  The settings you reference are not working, no matter which shortcuts I choose.

7-14-21: What worked this time was to set to system defaults in keyboard settings, then reboot and reset off system defaults.  This worked on both my desktop pc and a laptop with xubuntu installed on it.

Offline

Board footer

Powered by FluxBB