Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-02-20 16:22:17

__ap__
Member
Registered: 2021-02-20
Posts: 2

xfce4-notifyd doesn't start automatically

Hello,

This started happening today after I moved my installation on a new storage (weirdly). I noticed that "xfce4-notifyd" wasn't started automatically anymore. However I can start it manually using `systemctl --user start xfce4-notifyd`and it works.

I went through this topic: https://forum.xfce.org/viewtopic.php?id=11382

If I look at `journalctl` it seems that d-bus doesn't attempt to start it automatically:

$ journalctl -b --user -u dbus.service | grep notify
$ journalctl -b --user -u xfce4-notifyd
-- Logs begin at Sat 2021-02-20 15:38:34 CET, end at Sat 2021-02-20 17:18:10 CET. --
-- No entries --
$ 

I'm in the case that I already have some KDE components installed, and therefore there may be a conflict as explained here, however I never had anything to do about it before.

Offline

#2 2021-02-20 16:50:26

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,415

Re: xfce4-notifyd doesn't start automatically

Hello and welcome.

Which distro and version of xfce4-notifyd are you running? If your distro builds a newer version of xfce4-notifyd with the "--enable-dbus-start-daemon" parameter, then you would use systemctl/dbus to start/enable and run the service. Otherwise, it drops a .desktop file into /etc/xdg/autostart for the typical autostart method.

Is there an entry for the Xfce Notification Daemon in Settings Manager > Session and Startup > Application Autostart?
If it works by running it manually via systemctl, what happens if you "enable" it as well to automatically run on startup?

Also, is there something in your ~/.xsession-errors file about the xfce4-notifyd daemon?

Offline

#3 2021-02-20 16:58:53

__ap__
Member
Registered: 2021-02-20
Posts: 2

Re: xfce4-notifyd doesn't start automatically

Ok, I worked around this by creating the following file:

$ cat .config/autostart/xfce4-notifyd-autostart.desktop 
[Desktop Entry]
Type=Application
Name=xfce4-notifyd
Exec=/usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
OnlyShowIn=XFCE
NoDisplay=true
StartupNotify=false
Terminal=false
Hidden=false

To answer your questions:

ToZ wrote:

Which distro and version of xfce4-notifyd are you running?

Ubuntu 20.04, xfce4-notifyd 0.4.4-1.

Is there an entry for the Xfce Notification Daemon in Settings Manager > Session and Startup > Application Autostart?

There wasn't, but the file I added above added one smile

Also, is there something in your ~/.xsession-errors file about the xfce4-notifyd daemon?

Nothing except a harmless (I suppose) theme parsing error.

Offline

Board footer

Powered by FluxBB