Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-03-22 14:27:09

fyulita
Member
Registered: 2021-03-22
Posts: 5

Thunar shortens my folder names

Hi! I've been using Thunar for several months but for some just recently it started shortening the names of some of my folders.

Shortened folders

In that image you can see how my folders "Estructura de la Materia 2" and "Estructura de las Materia 3" are shortened both to "Estructura de la", which is annoying and confusing. For some reason I noticed that if I were to make another folder like "this is a folder with a really long name" then the folder fixes itself!

Unshortened folders

But if instead of naming that folder "this is a folder with a really long name" I name it "Estructura de la Materia 4" then the problem reappears!

I appreciate any help regarding this :)

EDIT:

This is how I fixed it:

fyulita wrote:

Ok, apparently this is a bug in xfce-exo that was introduced some months ago. It hasn't been fixed yet so what I did was use the Arch Linux Archive to downgrade exo to a previous package, specifically to exo-0.12.11-5-x86_64.pkg.tar.zst. You can see the archive here. I'll leave the links to the issue I created and to the links that led me to solve this:

- Issue I made
- Another person with the similar issue
- The commit that fixes the bug (I think...)
- How to downgrade a package using the Arch Linux Archive

I hope all this info is useful to someone else.

Last edited by fyulita (2021-03-29 22:49:06)

Offline

#2 2021-03-22 19:22:11

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,557

Re: Thunar shortens my folder names

Hello and welcome.

What version of thunar are you running (and which distro)?

What is the name of the appearance (GTK)  theme you are using? Does the same problem happen with other themes?

Can you create a secondary user on your system and log in as that user with the default settings? See if you can replicate the problem there.

Offline

#3 2021-03-22 20:42:25

fyulita
Member
Registered: 2021-03-22
Posts: 5

Re: Thunar shortens my folder names

ToZ wrote:

Hello and welcome.

What version of thunar are you running (and which distro)?

What is the name of the appearance (GTK)  theme you are using? Does the same problem happen with other themes?

Can you create a secondary user on your system and log in as that user with the default settings? See if you can replicate the problem there.

Neofetch

Im running ArchLinux x86_64 with Thunar 4.16.5-1 thunar-volman 4.16.0-1 (the latest versions as I can see).

The GTK theme I'm using is called oomox-creem and the icons are called oomox-Cream (I don't remember where I got those from, probably reddit, but they've worked so far). I changed my theme to Raleigh and my icons to Adwaita and the names are still shortened.

I created a second user and curiously it works fine that way, it doesn't shorten the names. Same thing if I use Thunar with superuser. So the problem only exists for my user.

Offline

#4 2021-03-22 21:57:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,557

Re: Thunar shortens my folder names

It must be a setting specific to your user profile.

Do you have any content in ~/.config/gtk-3.0/gtk.css or ~/.config/gtk-3.0/settings.ini? If so, can you post?

Also, change the GTK theme to its default:

xfconf-query -c xsettings -p /Net/ThemeName -s ""

...and log out and back in again to test.

Offline

#5 2021-03-23 00:22:39

fyulita
Member
Registered: 2021-03-22
Posts: 5

Re: Thunar shortens my folder names

ToZ wrote:

It must be a setting specific to your user profile.

Do you have any content in ~/.config/gtk-3.0/gtk.css or ~/.config/gtk-3.0/settings.ini? If so, can you post?

Also, change the GTK theme to its default:

xfconf-query -c xsettings -p /Net/ThemeName -s ""

...and log out and back in again to test.

I don't have a gtk.css file but I do have a settings.ini:

[Settings]
gtk-theme-name=oomox-creem
gtk-icon-theme-name=oomox-Cream
gtk-font-name=mononoki Nerd Font 12
gtk-cursor-theme-name=Breeze_Snow
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_BOTH
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintfull

Also, when I execute that code you posted it returns:

Property "/Net/ThemeName" does not exist on channel "xsettings". If a new property should be created, use the --create option.

I think that the problem in there is that I don't have a channel called "xsettings". I do have a channel called thunar but there is no "/Net/ThemeName" property or similar. These are the properties of thunar:

/last-details-view-column-widths
/last-details-view-zoom-level
/last-icon-view-zoom-level
/last-location-bar
/last-separator-position
/last-side-pane
/last-sort-column
/last-sort-order
/last-view
/last-window-height
/last-window-maximized
/last-window-width
/misc-single-click
/misc-text-beside-icons

Offline

#6 2021-03-23 02:32:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,557

Re: Thunar shortens my folder names

fyulita wrote:
Property "/Net/ThemeName" does not exist on channel "xsettings". If a new property should be created, use the --create option.

I think that the problem in there is that I don't have a channel called "xsettings". I do have a channel called thunar but there is no "/Net/ThemeName" property or similar.

I just realized you're not running Xfce, just thunar. Hence the missing xsettings category.

I'm not sure what other settings might affect the layout in thunar in your scenario. The settings.ini file looks okay.  Maybe try changing the font? I'm not that familiar with xmonad.

Offline

#7 2021-03-23 15:11:12

fyulita
Member
Registered: 2021-03-22
Posts: 5

Re: Thunar shortens my folder names

ToZ wrote:
fyulita wrote:
Property "/Net/ThemeName" does not exist on channel "xsettings". If a new property should be created, use the --create option.

I think that the problem in there is that I don't have a channel called "xsettings". I do have a channel called thunar but there is no "/Net/ThemeName" property or similar.

I just realized you're not running Xfce, just thunar. Hence the missing xsettings category.

I'm not sure what other settings might affect the layout in thunar in your scenario. The settings.ini file looks okay.  Maybe try changing the font? I'm not that familiar with xmonad.

The font doesn't seem to be the problem. I noticed that the shortening arises from the amount of characters that the folders have. If add or remove one or two characters from the folder's name then it doesn't shorten it anymore. The same happens when I create a new folder with one or two more (or less) characters, which explains why when I create the folder called "this is a folder with a really long name" then the problem disappears. Also, if I change the spaces for dashes the problem disappears, so the spaces may have something to do with it (?

Offline

#8 2021-03-23 23:26:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,557

Re: Thunar shortens my folder names

Perhaps best to create a bug report and see if the developer has an idea as to what might be affecting this.

Offline

#9 2021-03-29 22:47:15

fyulita
Member
Registered: 2021-03-22
Posts: 5

Re: Thunar shortens my folder names

Ok, apparently this is a bug in xfce-exo that was introduced some months ago. It hasn't been fixed yet so what I did was use the Arch Linux Archive to downgrade exo to a previous package, specifically to exo-0.12.11-5-x86_64.pkg.tar.zst. You can see the archive here. I'll leave the links to the issue I created and to the links that led me to solve this:

- Issue I made
- Another person with the similar issue
- The commit that fixes the bug (I think...)
- How to downgrade a package using the Arch Linux Archive

I hope all this info is useful to someone else.

Offline

Board footer

Powered by FluxBB