Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-05-10 13:30:03

tigerbeard
Member
Registered: 2019-01-12
Posts: 9

.gtkrc-2.0 file option to modify GftTreeView spacing

I would like to have all TreeViews in the GUI displayed with as little vertical clearance as possible. Currently in my ~/.gftrc-2.0 file there are the following settings that made the situation a bit better, but still I am seeing vertical padding between the rows in the TreeView.

This is currently part of my ~/.gftrc-2.0 file. I removed the not relevant stuff for TreeViews ( the '...'):

 style "gtkcompact" {
 font_name="Sans 8"
 ...
 GtkTreeView::vertical-separator=0
 GtkTreeView::horizontal-separator=0 
 GtkTreeView::expander-size=8
 GtkTreeView::fixed-height-mode=TRUE 
 GtkWidget::focus_padding=0
 }
 class "GtkWidget" style "gtkcompact"

On the GTK site I read that the GtkCellRenderers  have additional padding in their parameters "yalign" and "ypad". "ypad" should have 0 as default anyway, but "yalign" seems what I am looking for as it defines a vertical padding between two cells. Its range is [0.0, 1.0] and the default is 0.5 and I would need that to be zero.

I did not find how to call it from the rc file.

 #This did not work: 
 GtkCellRendererPixbuf::yalign=0.0
 GtkCellRendererText::yalign=0.0
 #This did also not work: 
 GtkTreeView::GtkCellRendererPixbuf::yalign=0.0
 GtkTreeView::GtkCellRendererText::yalign=0.0
 #This did also not work: 
 GtkCellRenderer::yalign=0.0

How can I get this value to 0.0 in my current scheme?
Is the ~/.gftrc-2.0 config file the right place?

edit: I have seen this post How can I change the line height in the Xfce4 interface, but that parameter listed there is already in the rc file above.
edit2: I tested with the gftInspector the tree in the file manager, but could not find a suitable parameter in the tool

Last edited by tigerbeard (2021-05-10 16:27:21)

Offline

Board footer

Powered by FluxBB