Xfce Forum

Sub domains

You are not logged in.

#1 2021-10-02 18:52:37

jeff story
From: Shelton, WA, USA
Registered: 2011-05-09
Posts: 21

xfce4-terminal "--display=display" option

Quote: man xfce4-terminal dated 12/22/2020,  xfce4-terminal-0.8.10-2

General Options
           Default X display to use.

Window Options
           X display to use for the last- specified window.

I'm not understanding what to use or how to implement these options. It seems xfce4-terminal ignores the variable 'DISPLAY=:0.1' in a dual XScreen setup that works with non xfce stuff. So I'm trying to use the options above, without any luck. I really don't know the format to use and have not found a source for that info. I have tried the following:

/usr/bin/xfce4-terminal --display=:0.1
/usr/bin/xfce4-terminal --display=DISPLAY=:0.1
/usr/bin/xfce4-terminal --display=0.1
/usr/bin/xfce4-terminal --display=1
/usr/bin/xfce4-terminal --display=2

/usr/bin/xfce4-terminal --default-display=:0.1
/usr/bin/xfce4-terminal --default-display=DISPLAY=:0.1
/usr/bin/xfce4-terminal --default-display=0.1
/usr/bin/xfce4-terminal --default-display=1
/usr/bin/xfce4-terminal --default-display=2

All the above variations open a terminal in DISPLAY=:0.0 without reporting errors.

My system is setup with the main display being DISPLAY=:0.0, and second display being DISPLAY=:0.1.

All non xfce4 applications I have still use the DISPLAY variable. ie:

DISPLAY=:0.1 lxterminal

opens a terminal window in the second display.

The second display (DISPLAY=:0.1) remains black, but shows the mouse cursor in the current version of XFCE, until I launch something in it.

I can start some xfce4 stuff with workarounds like dbus-run-session, etc from the console, but it results in overall unstable xfce behavior.

I'd sure like to run a full screen xfce4-terminal in the second display if it's possible. Hoping I'm just missing the correct options to use per above.

Last edited by jeff story (2021-10-02 18:57:56)


Board footer

Powered by FluxBB