Xfce Forum

Sub domains
 

You are not logged in.

#1 2021-11-30 10:07:45

whiskermenu
Member
Registered: 2021-11-30
Posts: 2

disable opening whisker menu when pressing super (win) key

Hi!

After upgrading my xubuntu to 21.10, the whisker menu started to open when I press super (win) key. Is there a way to disable this? I use super key in a lot of hot-key combinations, and whisker menu often gets in the way.

I tried to check settings, googled it, tried to remove and add whiskermenu widget, checked application shortcut settings, but I didn't succeed. Any help is appreciated.

Offline

#2 2021-11-30 11:53:04

mr_glitch
Member
From: Poland
Registered: 2021-08-02
Posts: 14
Website

Re: disable opening whisker menu when pressing super (win) key

Go to Session and Startup > Application Autostart and check do you have xcape enabled (on login). It will be something like "xcape -e 'Super_L=Alt_L|F1'" when you hover the item.

I don't use Ubuntu, but it is how it goes on Manjaro.

Offline

#3 2021-11-30 16:23:57

PaperNick
Member
Registered: 2013-05-26
Posts: 94

Re: disable opening whisker menu when pressing super (win) key

Hello and welcome!

Alternatively, you can check in Settings Manager -> Keyboard -> Application Shortcuts (tab) and search for xfce4-popup-whiskermenu entry assigned to the Super button. If there is such an entry, simply delete it.

Offline

#4 2021-12-08 15:45:51

whiskermenu
Member
Registered: 2021-11-30
Posts: 2

Re: disable opening whisker menu when pressing super (win) key

Thank you very much for prompt response!

I tried both options, the first one is with xcape. If I run it without arguments, it seems to be working, thanks. As of keyboard shortcuts, I checked, there is no shortcut assigned in "Applications shortcuts".

Looking at the code, I think it is this bug that was recently fixed: https://github.com/gottcode/xfce4-whisk … 892bae9aaf , but I can wrong.

Thanks everyone!

Offline

Board footer

Powered by FluxBB