Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-04-13 12:29:06

pao.pao
Member
Registered: 2022-04-13
Posts: 3

XFCE (in Manjaro) NetworkManager cannot disable IPv6

Hi guys, I'm trying to set up a VPN. I'm encountering an issue, when I tweak the settings of the VPN, under Edit Connections (network manager) I choose the option to disable IPv6 (or ignore it) and neither option works. IPv6 continues to be projected. The VPN claims it's the problem of my software, because they don't support IPv6 yet, and I can't disable it.

Any ideas why I cannot disable IPv6?

Thanks!

Offline

#2 2022-04-13 14:18:17

KBar
Moderator
Registered: 2021-11-05
Posts: 645

Re: XFCE (in Manjaro) NetworkManager cannot disable IPv6

Hello.

Best bet is to blacklist its from ever loading. Reboot your computer and get into GRUB command-line. Add these two parameters:

ipv6.disable=1 module_blacklist=ip6_tables

and proceed with the boot-up. If it works and fixes your problem, add them to your GRUB config file to set it permanently and then run:

sudo update-grub

Remember to edit the subject of your topic to include the [SOLVED] tag once you're satisfied with the answers or have found a solution (in which case, don't forget to share it as well), so that other members of the community can quickly refer to it and save their time. Pretty please! tongue

Offline

#3 2022-04-13 21:54:36

pao.pao
Member
Registered: 2022-04-13
Posts: 3

Re: XFCE (in Manjaro) NetworkManager cannot disable IPv6

Success!

Thank you so much KBar!



Reference for other users reading this:

I made the changes suggested following these guides:

https://wiki.archlinux.org/title/IPv6#Disable_IPv6

https://wiki.archlinux.org/title/Kernel_parameters

to make the changes to GRUB, using grub-mkconfig


The purpose of all this was disabling IPv6 since my VPN doesn't support it, and I was still projecting the address since only IPv4 was being changed.



All the best!!

Offline

Board footer

Powered by FluxBB