Xfce Forum

Sub domains
 

You are not logged in.

#1 2022-05-07 12:37:29

jt1122
Member
Registered: 2021-03-26
Posts: 100

galculator scrollbar issue

Hi,

When galculator is in "paper mode" and there multiple lines a scroll bar appears on the right.
However it has an auto-hide/auto-appear annoying behaviour and it hides the results on the rhs, which is kind of silly.

Is there a way to disable this auto-hide behaviour or shift it to the left?.

Thanks

Offline

#2 2022-05-07 17:38:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: galculator scrollbar issue

Is there a way to disable this auto-hide behaviour

There are two approaches to disabling overlay scrollbars.

If its just for galculator, then run galculator like this:

GTK_OVERLAY_SCROLLING=0 galculator

If you want to disable overlay scrolling for all GTK3 apps, add:

gtk-overlay-scrolling = false

...to ~/.config/gtk-3.0/settings.ini. Note, if you don't have an existing settings.ini file you will need to create one. It needs to start with a "[Settings]" line, so something like:

[Settings]
gtk-overlay-scrolling = false

shift it to the left

As far as I know, there is no way to move the position of the scrollbar in a scrolledwindow unless you change the code.

Offline

#3 2022-05-07 18:41:06

jt1122
Member
Registered: 2021-03-26
Posts: 100

Re: galculator scrollbar issue

great, thanks.

Is there a way to disable the bars just ofr galculator in the settings.ini file?.

Should that be in gtk-3 or gtk-4 (as with mousepad)?

Cheers

Offline

#4 2022-05-07 19:49:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 8,817

Re: galculator scrollbar issue

The settings.ini file will apply to all GTK3 apps. And unfortunately, galculator does not publish any app-specific style classes so that you can direct CSS overrides against. The only way to disable them would be with an option or setting in galculator - which doesn't exist.

Offline

#5 2022-05-08 10:02:20

jt1122
Member
Registered: 2021-03-26
Posts: 100

Re: galculator scrollbar issue

Thanks again.

Offline

Board footer

Powered by FluxBB