Xfce Forum

Sub domains

You are not logged in.

#1 2022-06-15 14:32:17

Registered: 2019-11-15
Posts: 16

pulseaudio - unable to enable 'module-echo-cancel'

i'm trying to follow
https://codepre.com/how-to-enable-echo- … audio.html
to enable noise cancelling on pulse audio on debian stable xfce.

i'm unable to load the module at all. the module file is present.
when i run "pactl load-module module-echo-cancel" (after running "pactl unload-module module-echo-cancel" to unload, but it's not loaded), i get the message:

"Failure: Module initialization failed".

journalctrl shows:

"Failed to load module "module-echo-cancel" (argument: ""): initialization failed.
Can't cancel echo between a sink and its monitor"

i don't have any special config for pulse audio except a few other modules enabled.

one strange thing i noticed, is that if i enable the pulse audio equalizer, and switch to the equalized output in pavucontrol, then i can enable the module, but then pulse crashes and wont restart. (and the eq is deprecated anyway.)

i also tried disabling the 'module-equalizer-sink', and then loading 'module-echo-cancel', just in case, but no dice.

does anyone have any suggestions as to why the echo-cancel module won't load for me? there's v little info about this problem online, as far as i can see.

EDIT: my manual configurations for pulse, added to "/etc/pulse/default.pa", are as follows:

### Load the integrated PulseAudio equalizer and D-Bus module
load-module module-equalizer-sink
load-module module-dbus-protocol

load-module module-switch-on-connect

Last edited by mouseboot (2022-06-15 14:37:47)


Board footer

Powered by FluxBB