Xfce Forum

Sub domains
 

You are not logged in.

#1 2023-01-24 07:48:05

Acode
Member
Registered: 2022-04-30
Posts: 9

[Solved] How do I enable Disable touchpad while typing toogle?

Hi there, I am using Linux Mint 21.1, due to some reason "Disable touchpad while typing" toogle isn't showing in the "Mouse and Touchpad" setting. How can I enable that setting because it's very handy to diable and enable touchpad while typing using that setting. Neither Enable horizontal scrolling toogle is showing.

This is what's showing in my desktop
my settings

But, I want this
my settings

Last edited by Acode (2023-01-25 12:51:35)

Offline

#2 2023-01-24 16:53:22

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,759

Re: [Solved] How do I enable Disable touchpad while typing toogle?

xfce4-settings has much better support for the synaptics driver than it does for libinput. I'm guessing that libinput is running on the first screenshot and synaptics on the second.

You could install the synaptics driver on your computer (and it should supercede libinput) and then the checkbox would appear. Or you could set the libinput property directly via the command line. To do so, have a read through https://forum.xfce.org/viewtopic.php?id=13451 and follow the process linked at https://elementaryos.stackexchange.com/ … ile-typing.

Offline

#3 2023-01-25 05:57:14

Acode
Member
Registered: 2022-04-30
Posts: 9

Re: [Solved] How do I enable Disable touchpad while typing toogle?

Thank you ToZ for helping me out, I searched for "Does linux mint uses libinput or synaptics" then I found this webpage describing the whole process. I am explaining it below so that it could help other peoples too.

Link to the webpage

TL;DR:
To use synaptics driver, Just use this command and log out and log back in.

sudo apt install xserver-xorg-input-synaptics

To know which driver is used by your input devices, run the following command:

grep -i "Using input driver" /var/log/Xorg.0.log

When both (libinput+synaptics) drivers are installed, "synaptics" takes priority.

To switch to the "synaptics" driver, install it with the command:

apt install xserver-xorg-input-synaptics

Then log out and log back in.

To go back to using "libinput", simply remove the "synaptics" driver:

apt remove xserver-xorg-input-synaptics

Then log out and log back in.

Offline

#4 2023-01-25 11:25:57

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,759

Re: [Solved] How do I enable Disable touchpad while typing toogle?

Thanks for reporting back and the detailed info. Can you mark this thread as solved by editing your original post and prepending "[SOLVED]" to the subject line?

Offline

#5 2023-01-25 12:52:58

Acode
Member
Registered: 2022-04-30
Posts: 9

Re: [Solved] How do I enable Disable touchpad while typing toogle?

Thanks for reminding me, i did it.

Offline

Board footer

Powered by FluxBB