Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-02-28 13:30:33

Xgh84u9t
Member
Registered: 2024-02-28
Posts: 4

Disable workspace switching using alt + forward/back mouse buttons

Hello, how can I disable the key bind for switching workspaces using the alt key + the forward/back buttons of the mouse? Seems this is build in somehow, because I haven't configured it. But cannot find any option to disable this. Thanks for your help.

Offline

#2 2024-02-28 19:57:29

jaywilkas
Member
Registered: 2021-06-05
Posts: 19

Re: Disable workspace switching using alt + forward/back mouse buttons

XFCE settings -> Window manager -> Keyboard

Offline

#3 2024-02-28 23:26:52

Xgh84u9t
Member
Registered: 2024-02-28
Posts: 4

Re: Disable workspace switching using alt + forward/back mouse buttons

There is no key bind configured for the next/previous workspace

Offline

#4 2024-02-28 23:43:13

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,985

Re: Disable workspace switching using alt + forward/back mouse buttons

This isn't something that would be configured in Xfce proper. Are you using xbindkeys (look for an ~/.xbindkeysrd file and an xbindkeys process) or something like imwheel for this functionality?


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#5 2024-02-28 23:58:41

Xgh84u9t
Member
Registered: 2024-02-28
Posts: 4

Re: Disable workspace switching using alt + forward/back mouse buttons

I'm not using the tools xbindkeys, imwheel or something similar to configure keybinds. I'm only using the settings XFCE provides under "XFCE settings -> Window manager" and "XFCE settings -> Keybord" for this.

Offline

#6 2024-02-29 00:33:11

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 10,985

Re: Disable workspace switching using alt + forward/back mouse buttons

Actually, here it is. Button 8 and 9 plus the easy_click key (Settings Manager > Window Manager Tweaks > Accessibility) key combination moves the workspace left and right.

Unfortunately it is hard-coded, unless you change the value of "Key used to grab and move windows". Mind you, if you change this, it might change the functionality of grabbing and moving windows.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#7 2024-02-29 14:40:08

Xgh84u9t
Member
Registered: 2024-02-28
Posts: 4

Re: Disable workspace switching using alt + forward/back mouse buttons

Although it's hard coded it already helps that I can change the activating key. Thank you very much!

Offline

Board footer

Powered by FluxBB