Xfce Forum

Sub domains
 

You are not logged in.

#1 2024-04-20 17:14:55

Augie77
Member
Registered: 2024-04-20
Posts: 8

[SOLVED] I need libxfce4ui-2 >= 4.18.4

Debian Bookworm 12.5, XFCE 4.18

Only been using Linux for a year and a half now, so I am lacking in finding missing dependencies. I successfully built and installed xfce4-terminal 1.1.3 and am attempting to install xfce4-power-manager 4.19.2. Prior to the power manager attempt I did this in terminal

sudo apt build-dep xfce4-power-manager

I then did

./configure

and was advised that I needed libxfce4ui-2 >= 4.18.4.

The Debian repository only (that I know of) contains the 4.18.2 version. Where do I find the 4.18.4 or later version?

Thanks

Last edited by Augie77 (2024-04-22 19:24:01)

Offline

#2 2024-04-20 17:28:26

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 11,142

Re: [SOLVED] I need libxfce4ui-2 >= 4.18.4

The upstream Xfce packages can be found here. It looks like 4.18.4 exists in debian testing (trixie), however I'm no expert on debian packaging.


Please remember to mark your thread [SOLVED] to make it easier for others to find
--- How To Ask For Help | FAQ | Developer Wiki  |  Community | Contribute ---

Offline

#3 2024-04-20 17:56:46

Augie77
Member
Registered: 2024-04-20
Posts: 8

Re: [SOLVED] I need libxfce4ui-2 >= 4.18.4

I did stumble onto that site a few minutes ago and installed the libxfce4ui-4.19.5tr.bz2, which installed but a search on the libxfce4ui-2 still showed I was at the same release version.  I will try the 4.18 you linked to and see what happens. Does Debian 'block' upgrades on some packages?

Offline

#4 2024-04-20 18:28:16

Augie77
Member
Registered: 2024-04-20
Posts: 8

Re: [SOLVED] I need libxfce4ui-2 >= 4.18.4

Seem like it is a must to also do the

make install

as a final action. smile  I also needed to add the libxfce4util, which passed. Install the power-manager went OK however, after a reboot, I get a popup asking to start the power manager, selecting yes only causes the box to popup and repeat again. I disabled the autostart and will tinker with this later. As it is, 4.18 version of power-manager is still installed. I will delete/reinstall with Snyaptic, or do a Timeshift restore.

edit:: did a Timeshift back to sanity. smile

Last edited by Augie77 (2024-04-20 18:40:16)

Offline

Board footer

Powered by FluxBB