Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-07-06 11:36:21

Vysserk3
Member
Registered: 2011-07-06
Posts: 5

How NOT to wrap icon text on the desktop ?

Hi !
I was wondering if it was possible to customize the length of the icon text that is displayed on the screen...because, right now, the text is wrapped after only 10 chars...
1309952154.png

Thanks

Offline

#2 2011-07-07 17:34:37

s0ulslack
Moderator
From: Idaho
Registered: 2005-12-25
Posts: 291

Re: How NOT to wrap icon text on the desktop ?

Hello Vysserk3,

Indeed there is, checkout http://git.xfce.org/xfce/xfdesktop/tree/README and read the HIDDEN CUSTOMIZATIONS portion

Offline

#3 2011-07-07 22:02:58

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 436
Website

Re: How NOT to wrap icon text on the desktop ?

Interesting.  Mine only has the last six items.  I take it that all I'd need to add would be the first three, then log out, log back in to have them take effect?


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#4 2011-07-09 14:19:03

Vysserk3
Member
Registered: 2011-07-06
Posts: 5

Re: How NOT to wrap icon text on the desktop ?

s0ulslack  > thx, but it seems the only relevant setting affects the cell size as well (and not only the text area) :

XfdesktopIconView::cell-text-width-proportion = 5

As you can see here 1310220937.gif, the entire text is visible (though it could use some line return) but cell spacing is way too big....

I've tried to change

XfdesktopIconVIew::cell-spacing = 0
XfdesktopIconView::cell-padding = 0

But without any success....

Any idea ? Would it be possible to use another program similar to xfdesktop ?

Last edited by Vysserk3 (2011-07-09 14:21:25)

Offline

#5 2011-07-10 08:17:40

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: How NOT to wrap icon text on the desktop ?

XfdesktopIconView::ellipsize-icon-labels = 0

Offline

#6 2011-07-10 08:44:26

Vysserk3
Member
Registered: 2011-07-06
Posts: 5

Re: How NOT to wrap icon text on the desktop ?

etnlWings > thx, but it doesn't change anything....

Offline

#7 2011-07-10 08:59:58

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: How NOT to wrap icon text on the desktop ?

Remove your earlier settings, or create a file with a really long name. Also xkill xfdesktop, to make sure changes take effect.

Offline

#8 2011-07-10 09:13:38

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: How NOT to wrap icon text on the desktop ?

With Xfce 4.6, disabling ellipsize makes icon text wrap properly.

http://ompldr.org/vOWZjYg/wrap.jpg

Offline

#9 2011-07-10 09:25:31

Vysserk3
Member
Registered: 2011-07-06
Posts: 5

Re: How NOT to wrap icon text on the desktop ?

I'm running Xfce 4.8.0.2 in Linux Mint Debian Edition. It might be a bug then ?

Offline

#10 2011-07-10 09:34:52

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: How NOT to wrap icon text on the desktop ?

Possibly.

Offline

#11 2011-07-10 13:49:01

s0ulslack
Moderator
From: Idaho
Registered: 2005-12-25
Posts: 291

Re: How NOT to wrap icon text on the desktop ?

Doesn't seem to work with 4.8.2 here either

Offline

#12 2011-07-10 14:08:50

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: How NOT to wrap icon text on the desktop ?

Must be a regression, then. The variable is still listed in the GIT readme.

Offline

#13 2011-08-08 01:01:27

jimezam
Member
Registered: 2011-08-08
Posts: 1

Re: How NOT to wrap icon text on the desktop ?

Please note that there are two typos in the README file: a capital 'I' where it should be 'i' in the following entries (see XfdesktopIconV[i/I]ew).

  - XfdesktopIconVIew::ellipsize-icon-labels = 1
                           ^
  - XfdesktopIconVIew::cell-spacing = 6
                           ^

If you copy/paste from there to your .gtkrc-2.0 file (as I did) this options will be ignored.

Maybe that is your problem too.

jimezam.

Last edited by jimezam (2011-08-08 01:01:55)

Offline

#14 2011-10-16 18:15:42

Vysserk3
Member
Registered: 2011-07-06
Posts: 5

Re: How NOT to wrap icon text on the desktop ?

jimezam > sorry for the delay, it works now with

XfdesktopIconView::ellipsize-icon-labels = 0


(I've tested this on Xubuntu 11.10 not Linux Mint though)

Offline

#15 2012-01-30 19:45:13

rabideau
Member
Registered: 2012-01-28
Posts: 6

Re: How NOT to wrap icon text on the desktop ?

Thank you for the pointer.  I have had a couple of frustrations with the XFCE desktop personally including:
1. the single line file descriptor on the Desktop -and-
2. the non-transparent background of the Desktop Icons

Courtesy of your leads I have both of the above "fixed" in my 4.8 XFCE Xubuntu 11.10 install.  My remaining frustration is that thumbnails do not function ala gnome 2 on my Desktop.  By way of sharing my solution(s) generated with your help here is a copy of my .gtkrc-2.0 file ... perhaps this will help another.

In terminal mode enter:

$ leafpad ~/.gtkrc-2.0

Then insert the following (change the colors to whatever you like):

style "xfdesktop-icon-view" {
    XfdesktopIconView::label-alpha = 0
    XfdesktopIconView::selected-label-alpha = 170
# XfdesktopIconVIew::ellipsize-icon-labels = 2 (old non-wrapping icon label with error)
    XfdesktopIconView::ellipsize-icon-labels = 0

    XfdesktopIconView::shadow-x-offset = 0
    XfdesktopIconView::shadow-y-offset = 0
    XfdesktopIconView::shadow-color = "#000000"
    XfdesktopIconView::selected-shadow-x-offset = 0
    XfdesktopIconView::selected-shadow-y-offset = 0
    XfdesktopIconView::selected-shadow-color = "#ffffff"

    XfdesktopIconVIew::cell-spacing = 6
    XfdesktopIconView::cell-padding = 6
    XfdesktopIconView::cell-text-width-proportion = 2.5

    base[NORMAL] = "#cccccc"
    base[SELECTED] = "#cccccc"
    base[ACTIVE] = "#cccccc"

    fg[NORMAL] = "#ffffff"
    fg[SELECTED] = "#000000"
    fg[ACTIVE] = "#000000"
}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

Again, thanks!

Offline

Board footer

Powered by FluxBB