Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-09-02 01:59:13

varx
Member
Registered: 2011-09-01
Posts: 7

[Solved] How can I keep my browser from workspace hopping?

I usually keep my e-mail client (Thunderbird, currently) and my browser (Firefox, currently) in separate workspaces. Problem: When I'm using Thunderbird in workspace 2 and click on a web link in an e-mail message, it brings Firefox from workspace 1 over to workspace 2 and goes to the linked site. How can I retain this link-opening behavior but keep my browser in its originial workspace?

Thanks.

Last edited by varx (2011-09-02 01:59:49)

Offline

#2 2011-09-02 05:46:43

daggoth
Member
From: New Zealand
Registered: 2009-03-05
Posts: 42

Re: [Solved] How can I keep my browser from workspace hopping?

I suggest that you install devilspie, a utility that lets you perform various operations on windows. Operations like maximize, minimize, focus, set workspace to N, that sort of thing. Whenever a new window or tab is opened, devilspie acts on that window according to a set of rules that you specify.

apt-get install devilspie gdevilspie 

You can learn more about devilspie here and here and here and here. Or you can just use gdevilspie, a nice gui front-end to configure the rules with ease. In your case, you will want to specify a rule to 'set workspace' for any firefox windows.

The other utility that is sometimes useful for taming windows is wmctrl. Wmctrl and devilspie have different strengths... which I use depends upon the situation.

Offline

#3 2011-09-02 15:07:37

varx
Member
Registered: 2011-09-01
Posts: 7

Re: [Solved] How can I keep my browser from workspace hopping?

Thanks, daggoth. At your suggestion, I've been playing with devilspie. It's a useful app, for sure. I can use devilspie to see that Firefox always opens in workspace 1. But if Firefox is already open in workspace 1 and I click on an e-mail link while I'm in workspace 2, Firefox still moves over to workspace 2. That's the behavior I'm trying to stop. I'd rather that the linked page open in Firefox and Firefox stay in workspace 1.

I was familiar with wmctrl, as I use it to let me switch workspaces using the keyboard rather than the pager app on the panel.

Any suggestions about my workspace-hopping problem? Thanks.

Offline

#4 2011-09-02 23:24:27

daggoth
Member
From: New Zealand
Registered: 2009-03-05
Posts: 42

Re: [Solved] How can I keep my browser from workspace hopping?

Okay then, thinking... I may have headed you off in the wrong direction. Look at my settings in 'Windows Tweaks'. Have you selected the option to "Switch to window's workplace"?

Offline

#5 2011-09-03 00:14:16

varx
Member
Registered: 2011-09-01
Posts: 7

Re: [Solved] How can I keep my browser from workspace hopping?

daggoth wrote:

Okay then, thinking... I may have headed you off in the wrong direction. Look at my settings in 'Windows Tweaks'. Have you selected the option to "Switch to window's workplace"?

Thanks, daggoth. That did the trick. I should have explored the built-in features of xfce a little more. Still, I'm glad to know about devilspie. I like finely grained controls, whether they're built-in or via third-party code. And I like fooling with config files. So, thanks.

Offline

#6 2011-09-03 00:40:50

daggoth
Member
From: New Zealand
Registered: 2009-03-05
Posts: 42

Re: [Solved] How can I keep my browser from workspace hopping?

You're welcome...

Offline

#7 2011-09-03 00:58:29

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 431
Website

Re: [Solved] How can I keep my browser from workspace hopping?

Daggoth, if I were to try to install devilspie using your code, I can guarantee that it wouldn't work, because apt-get is Debian specific.  Using Fedora, I'd have to use yum.  You might want to consider mentioning that your code's distro-specific in the future to avoid confusing people who are new to Linux.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#8 2011-09-03 03:15:39

varx
Member
Registered: 2011-09-01
Posts: 7

Re: [Solved] How can I keep my browser from workspace hopping?

Sideburns wrote:

Daggoth, if I were to try to install devilspie using your code, I can guarantee that it wouldn't work, because apt-get is Debian specific.  Using Fedora, I'd have to use yum.  You might want to consider mentioning that your code's distro-specific in the future to avoid confusing people who are new to Linux.

True, a new user could be confused (I'm sure I would have been at one point). In daggoth's defense, Ubuntu has such a large userbase that Debian-speak has practically become a global Linux language.

Offline

#9 2011-09-04 01:03:40

daggoth
Member
From: New Zealand
Registered: 2009-03-05
Posts: 42

Re: [Solved] How can I keep my browser from workspace hopping?

Sideburns wrote:

You might want to consider mentioning that your code's distro-specific in the future to avoid confusing people who are new to Linux.

In hindsight I agree. Altho the gdevilspie link I gave above has a simple install method that works for all distros.

Offline

Board footer

Powered by FluxBB