Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-06-07 00:25:31

Nuc72
Member
Registered: 2012-06-07
Posts: 15

[Solved] No event sounds

Hi Guys,

could you help me please, how can i get event sounds to work? Xubuntu 12.04, Xfce 4.10. (Also tried on Xubuntu 11.10 with Xfce 4.8 -> without success.)
I've checked out Event Sounds on Appearance, and installed gnome-session-canberra, but there are no event sounds (other sounds are OK, I could listen mp3s, streaming medias etc.). I've PulseAudio.

Any idea? Thanks in advance.

Offline

#2 2012-06-07 03:15:36

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,085

Re: [Solved] No event sounds

http://ubuntuforums.org/showthread.php?t=1869787
^^^This worked for me in Xubuntu 11.10/Xfce 4.8. However, according to that thread, it doesn't work on Xubuntu 12.04. I haven't been able to test it as I haven't upgraded yet.

Offline

#3 2012-06-07 10:32:41

Nuc72
Member
Registered: 2012-06-07
Posts: 15

Re: [Solved] No event sounds

Thank You very much for the reply. I've read the topic you offered, and maybe I'll try the solution for 11.10, but I'm interested in 12.04 primarily.
Any other experiences?

Offline

#4 2012-06-07 11:47:36

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] No event sounds

I use Fedora with LXDM and pavucontrol brought the necessary dependencies (basically libcanberra). Here sound events work OOTB.

Offline

#5 2012-06-07 13:49:49

Nuc72
Member
Registered: 2012-06-07
Posts: 15

Re: [Solved] No event sounds

secipolla: I've installed canberra. When I check canberra in synaptic, it shows all of the libcanberras are installed (except devs and dbgs) - but there is no sound. I've also checked volume levels with alsamixer and everywhere on the GUI. Still no sound.

edit: I'll check pavucontrol. Thanks!

Last edited by Nuc72 (2012-06-07 23:20:58)

Offline

#6 2012-06-07 23:23:09

Nuc72
Member
Registered: 2012-06-07
Posts: 15

Re: [Solved] No event sounds

I've checked pavucontrol - it is actually PulseAudio Volume Control in Menu > Multimedia - it's installed yet, but there are no (event) sounds (all volume sliders were set to 100%, none of them were muted).

The Event sound files are stored in /usr/share/sounds.
I've checked Menu > Settings > Settings Editor > xsettings > Net > SoundThemeName. It was "default". There is no folder in /usr/share/sounds called "default" - so I've inserted "freedesktop" in Value field (freedesktop sound theme is in sounds folder).
Still I can't hear event sounds...

Here http://forums.debian.net/viewtopic.php?f=6&t=59522 I've read it helps if I install moblin sound theme. I've done - still no sounds. (I've edited the appropriate field in Settings Editor of course.)

Last edited by Nuc72 (2012-06-08 00:20:39)

Offline

#7 2012-06-08 01:16:06

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] No event sounds

But what kind of event sounds are you expecting?
I think the freedesktop theme is the default. For example, do you hear a sound when you get a new mail in Thunderbird*? If yes then the event sounds are working.

* the default sound is a very subtle 'thump' so you may want to raise the sound level for event sounds in pavucontrol.

Last edited by secipolla (2012-06-08 01:17:19)

Offline

#8 2012-06-08 01:38:52

Nuc72
Member
Registered: 2012-06-07
Posts: 15

Re: [Solved] No event sounds

Usually I check it with emptying trash. There is a "trash-empty" sound in freedesktop theme (it's quite loud as I played it in Parole). I remember (maybe I'm wrong) there was a "tic-tac" sound in Ubuntu if I clicked on a radio button - maybe there is no such event in freedesktop.

P.S.: I don't use Thunderbird, but Evolution instead - so I don't know Thunderbird is whistling or not :-) but Evolution is quiet just like a tomb.

Last edited by Nuc72 (2012-06-08 01:44:11)

Offline

#9 2012-06-08 02:20:57

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] No event sounds

You're running GNOME apps and are you running gnome-settings-daemon (GDM starts it by default)?
Because then you can set the event sounds with dconf-editor (gsettings).

* note that gnome-settings-daemon will run in place of xfsettingsd so maybe all your X settings (like fonts, themes etc.) will be managed by it.

Last edited by secipolla (2012-06-08 12:42:53)

Offline

#10 2012-06-08 13:11:33

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] No event sounds

Another thing you may try if you don't want to go to the gnome-settings-daemon route is create ~.config/gtk-3.0/settings.ini as explained at https://wiki.archlinux.org/index.php/Li … figuration (but I'm not sure if evolution will use it).

[Settings]
gtk-enable-event-sounds=true
gtk-enable-input-feedback-sounds=true
gtk-sound-theme-name=freedestop

Actually, I just tested with canberra-gtk-play (from libcanberra-gtk3 in Fedora) and it uses the freedesktop theme by default so if evolution isn't using it maybe you will have to look at its settings. But make sure system sounds is set to 100% in pavucontrol.

As for the trash empty thing, I just think that Thunar doesn't use it.

Last edited by secipolla (2012-06-08 14:29:32)

Offline

#11 2012-06-08 14:40:38

Nuc72
Member
Registered: 2012-06-07
Posts: 15

Re: [Solved] No event sounds

secipolla: Thank You for all of your ideas, I'll check them later and post the result. Maybe I give up, if Thunar does not use event sounds, i use Evolution instead of Thunderbird, there is no login and logout sounds in sound themes - so I can expect almost nothing from event sounds in Xfce.

Offline

#12 2012-06-08 15:00:53

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,085

Re: [Solved] No event sounds

I've got event sounds working in Xubuntu 12.04/Xfce 4.10. Just trying to figure out the secret combination. Do the following from this post: http://ubuntuforums.org/showpost.php?p= … ostcount=1 then from this post http://ubuntuforums.org/showpost.php?p= … stcount=14.

Offline

#13 2012-06-11 00:02:56

Nuc72
Member
Registered: 2012-06-07
Posts: 15

Re: [Solved] No event sounds

OK, finally I have Event Sounds in Xfce. :-)

Firstly I have to correct myself, cause I wrote in the opening of the topic I've tried event sounds in Xubuntu 11.10 with Xfce 4.8 WITHOUT success. It is not true. In 11.10 I had to install canberra only AND set system sound level higher than zero :-) (PulseAudio Volume Control). That's the true, I've made a login sound earlier with a script, so maybe I've installed sox yet. Sorry, I don't remember, but according to the following I think sox is very important.

What about 12.04?
You should install gnome-session-canberra AND sox only. And it's done. Check volume levels and muting in PAVC, and also check the entry called SoundThemeName in Settings Editor (xsettings > Net). I've changed it to freedesktop (maybe You shouldn't) and voilá, Xfce is tinkling!
I think You do not have to install dconf, because it inherits the important data from xfce4-settings.

Thanks everybody who helped and solved the problem finally!

Offline

Board footer

Powered by FluxBB