Xfce Forum

Sub domains

You are not logged in.

#1 2012-06-19 20:56:19

Registered: 2012-06-11
Posts: 6

[Solved] ssues with xfce4-power-manager-1.2.0

Hi all,

I have 2 issues I haven't been able to fix by myself yet :

  • suspend / hibernate don't work.

  • CPU Frequency control is hidden.

suspend / hibernate don't work

seb@goldfish:xfce4-power-manager --dump
       Xfce power manager version 1.2.0
Avec le support de policykit
Avec support du gestionnaire du réseau
Avec le support DPMS 
Peut se mettre en veille: Faux
Peut se mettre en veille prolongée: Faux
Arrêt des disques durs quand cela est possible: Vrai
Mode hibernation: Vrai
Autorisé à hiberner: Vrai
Autorisé à mettre hors tension: Vrai
Autorisé à réduire la vitesse de rotation des disques durs: Faux
A une batterie: Vrai
Régler la luminosité: Vrai
A un bouton de mise en marche: Vrai
A un bouton d'hibernation: Vrai
A un bouton de mise en veille: Vrai
A un couvercle: Vrai

Sorry if it's all french smile
translation of the 2 top lines is :
can suspend : false.
can hibernate : false.
Which is wrong. Support is compiled in the kernel :

seb@goldfish:grep SUSPEND /opt/src/linux-3.2.14/.config


echo mem > /sys/power/state

does work!
How does xfce4-power-manager check for suspend/hibernate ability?

CPU frequency control is hidden
The checkbox is missing from the extended settings tab.
But the frequency scaling is activated (and running).

seb@goldfish:lsmod | grep acpi
acpi_call               4047  0 
acpi_cpufreq            4929  1 
freq_table              1927  1 acpi_cpufreq
processor              22083  1 acpi_cpufreq
mperf                    875  1 acpi_cpufreq

My default governor is conservative.

Thanks for any clue on these 2 issues,


#2 2012-06-19 21:26:07

Registered: 2012-01-15
Posts: 393

Re: [Solved] ssues with xfce4-power-manager-1.2.0

Here in Fedora (I installed from minimal iso) I needed upower so suspend/hibernate would show up on the logout menu/power manager.


#3 2012-06-20 20:21:47

Registered: 2012-06-11
Posts: 6

Re: [Solved] ssues with xfce4-power-manager-1.2.0

Thanks for your suggestion. I actually have upower (0.9.15) installed, and running :

seb@goldfish:cat /var/log/daemon.log 
Jun 20 22:13:54 goldfish dbus[946]: [system] Activating service name='org.freedesktop.UPower' (using servicehelper)
Jun 20 22:13:54 goldfish dbus[946]: [system] Successfully activated service 'org.freedesktop.UPower'

Any other clue? neutral


#4 2012-07-10 20:24:15

Registered: 2012-06-11
Posts: 6

Re: [Solved] ssues with xfce4-power-manager-1.2.0

long time no see ! smile

After a loooong chase, I finally discovered here that upower was relying on a kernel function calling pm-utils to check for suspend/hibernate capability...

Installing pm-utils magically activated suspend/hibernate from xfce4-power-manager menu
(considering of course that polkit is correctly set up...)

me happy big_smile


Board footer

Powered by FluxBB