Xfce Forum

Sub domains

You are not logged in.

#1 2012-12-24 22:26:19

Registered: 2012-12-20
Posts: 4

[Solved] libxfce4util-4.10.0 makes fails when using Crosstool-ng

When make is run on the LIBXFCE4UTIL directory I get this error.

opensuse114:/usr/local/compiler/src/src/libxfce4util-4.10.0 # make && make install
make  all-recursive
make[1]: Entering directory `/usr/local/compiler/src/src/libxfce4util-4.10.0'
Making all in libxfce4util
make[2]: Entering directory `/usr/local/compiler/src/src/libxfce4util-4.10.0/libxfce4util'
make  all-am
make[3]: Entering directory `/usr/local/compiler/src/src/libxfce4util-4.10.0/libxfce4util'
  CC     libxfce4util_la-libxfce4util-aliasdef.lo
  CC     libxfce4util_la-libxfce4util-config.lo
  CC     libxfce4util_la-libxfce4util-private.lo
  CC     libxfce4util_la-xfce-fileutils.lo
  CC     libxfce4util_la-xfce-i18n.lo
  CC     libxfce4util_la-xfce-kiosk.lo
  CC     libxfce4util_la-xfce-license.lo
  CC     libxfce4util_la-xfce-miscutils.lo
xfce-miscutils.c: In function 'IA__xfce_putenv':
xfce-miscutils.c:404: warning: passing argument 1 of 'putenv' discards qualifiers from pointer target type
/usr/local/compiler/CT-OUT/s390x-ibm-linux-gnu/sysroot/usr/include/stdlib.h:557: note: expected 'char *' but argument is of type 'const gchar *'
  CC     libxfce4util_la-xfce-posix-signal-handler.lo
  CC     libxfce4util_la-xfce-rc.lo
  CC     libxfce4util_la-xfce-rc-config.lo
  CC     libxfce4util_la-xfce-rc-simple.lo
  CC     libxfce4util_la-xfce-resource.lo
  CC     libxfce4util_la-xfce-utf8.lo
  CCLD   libxfce4util.la
/usr/local/compiler/CT-OUT/lib/gcc/s390x-ibm-linux-gnu/4.4.5/../../../../s390x-ibm-linux-gnu/bin/ld: cannot find -lglib-2.0
collect2: ld returned 1 exit status
make[3]: *** [libxfce4util.la] Error 1
make[3]: Leaving directory `/usr/local/compiler/src/src/libxfce4util-4.10.0/libxfce4util'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/local/compiler/src/src/libxfce4util-4.10.0/libxfce4util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/compiler/src/src/libxfce4util-4.10.0'
make: *** [all] Error 2

in checking the configure step I see only one warning:

checking for s390x-ibm-linux-gnu-mt... no
checking for mt... mt
configure: WARNING: using cross tools not prefixed with host triplet
checking if mt is a manifest tool... no

Thanks for any help on this.

Last edited by AAFA (2012-12-24 22:27:25)


#2 2012-12-25 08:44:35

From: ~
Registered: 2005-02-17
Posts: 1,144

Re: [Solved] libxfce4util-4.10.0 makes fails when using Crosstool-ng

Has already been fixed by removing this function in git master ;-). The error is rather harmless, so compile without Werror should fix it too.


#3 2012-12-25 15:01:12

Registered: 2012-12-20
Posts: 4

Re: [Solved] libxfce4util-4.10.0 makes fails when using Crosstool-ng

Thanks for the Christmas response!

So reading configure --help

Should I use --without-werror=no?
Or should I down a patch for libxfce4util?

Also what is best place to search for these type xfce errors these forms?

Thanks for your time.

Last edited by AAFA (2012-12-25 15:03:20)


#4 2012-12-26 08:22:50

From: France
Registered: 2010-11-11
Posts: 131

Re: [Solved] libxfce4util-4.10.0 makes fails when using Crosstool-ng

You could try to use this before autogen.sh / configure / make:

export CFLAGS = "-Wno-error"


Board footer

Powered by FluxBB