Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-05-23 07:15:09

m68funk
Member
Registered: 2014-05-23
Posts: 2

How to set keyboard shortcuts

Running:


xfce 4.10.0-3 distributed bz Xubuntu
Linux Mint 16 Petra \n \l


How are Keyboard Shortcuts set?

I do understand that there is the Windomanager/Keyboard tab and that shortcut settings should reflect in: xfce4-keyboard-shortcuts.xml
of which are three on my machine:

locate xfce4-keyboard-shortcuts.xml
/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/home/mfunk/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

Also I picked up that changes ought to be be reloaded by the system afer a: xfdesktop --reload

But currently my machine is in a state, were it doesn't react to any changes of the shorcuts either in the Windomanager nor in the config files.
The windowmanager shows shortcuts like 'Add workspace' beeing mapped to '<Alt>Insert' but they arent mapped, as in don't work.

I haven't run through a reboot process yet, but either way I'd like to know a way to change the shortcut settings at runtime.
I'm using the IntelliJ IDE and I'd like to get the shortcuts that are shadowed by xfce out of my way.

Any hints on how to get that straight?

Cheers,

Martin

Offline

#2 2014-05-23 10:43:34

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,886

Re: How to set keyboard shortcuts

m68funk wrote:

How are Keyboard Shortcuts set?

I do understand that there is the Windomanager/Keyboard tab and that shortcut settings should reflect in: xfce4-keyboard-shortcuts.xml
of which are three on my machine:

locate xfce4-keyboard-shortcuts.xml
/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/home/mfunk/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

The first is the xfce default, the second is your currently active config file and the third looks like a mint-specific configuration file which mostly likely becomes the default on your system.

Also I picked up that changes ought to be be reloaded by the system afer a: xfdesktop --reload

I don't think this is correct. If you make the change by editing the shortcut at Settings Manager >> Window Manager >> Keyboard, it should be automatic. If you are doing it manually by editing the configuration file, you need to kill and restart the xfconfd module. On my system, i386, the command is:

killall xfconfd && /usr/lib/i386-linux-gnu/xfce4/xfconf/xfconfd &

...to force Xfce to re-read the file for changes (command will be in a different location for a 64-bit install).

But currently my machine is in a state, were it doesn't react to any changes of the shorcuts either in the Windomanager nor in the config files.
The windowmanager shows shortcuts like 'Add workspace' beeing mapped to '<Alt>Insert' but they arent mapped, as in don't work.

Is xfsettingsd running? If so, try restarting it. If not, fire it up to see if it helps.

I haven't run through a reboot process yet, but either way I'd like to know a way to change the shortcut settings at runtime.
I'm using the IntelliJ IDE and I'd like to get the shortcuts that are shadowed by xfce out of my way.

The easiest way is to make the change directly in Settings Manager >> Window Manager >> Keyboard (assuming your system is working properly to recognize those changes).

Offline

#3 2014-05-23 12:33:32

m68funk
Member
Registered: 2014-05-23
Posts: 2

Re: How to set keyboard shortcuts

Hm....

Using Window Manager >> Keyboard leads to a change in the user local xfce4-keyboard-shortcuts.xml
and it also is applied, as in the shortcut works after the Manager Window is closed.

running:

#!/bin/sh
killall xfconfd && /usr/lib/x86_64-linux-gnu/xfce4/xfconf/xfconfd &
killall xfsettingsd && xfsettingsd &

leaves the config file unchanged, but the shortcut drops back to default.
The configured shortcut doesn't work anymore, but the default works again.

I figure, if i restart the machine the sam effect would take place (not tested yet)

mf

Offline

#4 2014-05-23 13:49:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,886

Re: How to set keyboard shortcuts

If changing the shortcut via the front-end (Window Manager >> Keyboard) works, then there would be no need to restart xfconfd or xfsettingsd. On restart, the config file should be read and processed properly, but you'll need to test that.

Offline

#5 2019-01-15 08:38:18

Turo
Member
From: Spain
Registered: 2019-01-15
Posts: 2

Re: How to set keyboard shortcuts

Dear m68funk, I think it's a bug.
If you open the shortcuts menu in settings and delete the new configured one, there appears the last "default" shortcut like if it were on a "lower layer" or below the new configured one? If so, try deleting both shortcuts configured by pressing the "clear" button and then configure the one you want. This worked for me.

I hope you find it helpful...
Best regards.

Offline

#6 2019-09-17 10:39:07

butla
Member
Registered: 2019-09-17
Posts: 2

Re: How to set keyboard shortcuts

The path of xfconfd changed, I think. But I can confirm that

#!/bin/sh
killall xfconfd
/usr/lib/xfce4/xfconf/xfconfd &
xfsettingsd --replace &

as a script works to reload my keyboard shortcuts if I change them in the XML config file.

Offline

Board footer

Powered by FluxBB