Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-09-09 20:57:55

Gotolei
Member
Registered: 2014-03-05
Posts: 13

[Solved] Input feedback sounds in 4.10 (Xubuntu 14.04)

http://ubuntuforums.org/showthread.php?t=1869787
http://ubuntuforums.org/showthread.php?t=2219786

I've gone through both of those threads and still no dice. Posting here because my reply to the second thread was deleted.

I've enabled event and inputfeedback sounds in both dconf and xfconf, installed gnome-session-canberra and its dependencies, created the two files..
Only thing I've done differently is set the sound theme to freedesktop.

(terminal feedback from second thread's commands)

raster@meridian:~$ xfconf-query -c xsettings -p /Net/SoundThemeName
freedesktop
raster@meridian:~$ env | grep GTK_MODULE
raster@meridian:~$ ls /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo
alarm-clock-elapsed.oga        camera-shutter.oga              phone-incoming-call.oga
audio-channel-front-center.oga    complete.oga                  phone-outgoing-busy.oga
audio-channel-front-left.oga    device-added.oga              phone-outgoing-calling.oga
audio-channel-front-right.oga    device-removed.oga              power-plug.oga
audio-channel-rear-center.oga    dialog-error.oga              power-unplug.oga
audio-channel-rear-left.oga    dialog-information.oga              screen-capture.oga
audio-channel-rear-right.oga    dialog-warning.oga              service-login.oga
audio-channel-side-left.oga    message-new-instant.oga              service-logout.oga
audio-channel-side-right.oga    message.oga                  suspend-error.oga
audio-test-signal.oga        network-connectivity-established.oga  trash-empty.oga
audio-volume-change.oga        network-connectivity-lost.oga          window-attention.oga
bell.oga            onboard-key-feedback.oga          window-question.oga
raster@meridian:~$ which canberra-gtk-play
/usr/bin/canberra-gtk-play
raster@meridian:~$ xfconf-query -c xsettings -p /Net/EnableEventSounds
true
raster@meridian:~$ xfconf-query -c xsettings -p /Net/EnableInputFeedbackSounds
true

All I can see that might be out of place is 'env | grep GTK_MODULE' returned nothing.
But wasn't creating the two files in /etc/X11/Xsession.d supposed to fix that? Is there some sort of cache that needs to be rebuilt, or perms set?

I've restarted, and 'system sounds' is not muted (and is set ~60%) in pavucontrol.

Has something else changed since then? What am I missing?

Offline

#2 2014-09-09 22:35:00

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,085

Re: [Solved] Input feedback sounds in 4.10 (Xubuntu 14.04)

Your post at Ubuntuforums was actually moved to its own thread and I replied to it. No worries though. The fact that your not getting GTK_MODULES set is probably the reason. Can you post back the exact contents of the two files that you created:

cat /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
cat /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules

Event sounds work fine in my Xubuntu 14.04 install using those instructions.

Offline

#3 2014-09-09 23:12:28

Gotolei
Member
Registered: 2014-03-05
Posts: 13

Re: [Solved] Input feedback sounds in 4.10 (Xubuntu 14.04)

Ah, didn't see the new thread. Didn't even bother sending a notification or email or anything, how nice of them.

Anyway

No such file or directory

https://i.imgur.com/J1qEg5R.png

Not sure what to do at this point hmm

E: copy-pasted the names over again and cat's finding them this time around..?
No idea what's up with that, but rebooting..

E2: still no dice.

raster@meridian:~$ env | grep GTK_MODULE
GTK_MODULES=canberra-gtk-module:canberra-gtk-module
raster@meridian:~$ cat /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
	GTK_MODULES="canberra-gtk-module"
else
	GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES
raster@meridian:~$ cat /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules
# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
	GTK_MODULES="canberra-gtk-module"
else
	GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES

Last edited by Gotolei (2014-09-09 23:29:12)

Offline

#4 2014-09-09 23:47:15

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,085

Re: [Solved] Input feedback sounds in 4.10 (Xubuntu 14.04)

$ env | grep GTK_MODULE
GTK_MODULES=canberra-gtk-module:canberra-gtk-module

Okay, now GTK_MODULES is returning properly.

The freedesktop sound theme, imo, is lacking in sound effects. Try the modified Borealis sound theme that I threw together. Its linked to in post #6 in this thread.

Offline

#5 2014-09-09 23:56:47

Gotolei
Member
Registered: 2014-03-05
Posts: 13

Re: [Solved] Input feedback sounds in 4.10 (Xubuntu 14.04)

Changed to Borealis and it's making sounds now.

No volume change sound, which is mostly what I was going for.. but at least the other stuff works smile

Offline

Board footer

Powered by FluxBB