Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-10-04 19:08:51

bbatten
Member
Registered: 2015-10-04
Posts: 14

[Solved] "fvwm --replace" doesn't

For several years I ran xfce using fvwm as a window manager (I like the fvwm stroke library.). My login setup just uses a set of mgetty calls from /etc/inittab and a .bash_profile script in my home directory modified to invoke startx using the current virtual terminal with no client options.

The basic xfce configuration approach was to edit Session and Startup ->Application Autostart to invoke "fvwm --replace". Worked like a charm until a disastrous attempt to update from Debian Wheezy to Jessie.

The formerly working setup uses a modified .xinitrc that just calls /etc/X11/Xsession, which sources the various components. When .xsession is sourced, it exports FVWM_USERDIR and SM_SAVE_DIR, then does "exec startxfce4".

I'm now sorta back to square one: My xfce panels start and work more or less as expected. The problem is that my fvwm key bindings appear to be overridden by those of xfwm4. Using a terminal emulator, a modified pgrep shows that fvwm is running:

UID        PID  PPID  C STIME TTY          TIME CMD
bryan    28010     1  0 11:07 tty3     00:00:00 fvwm --replace

The same tool shows xfwm4 as *not* running. I also seem to have all the xfce components I need:

UID        PID  PPID  C STIME TTY          TIME CMD
bryan    27949     1  0 11:07 ?        00:00:00 /usr/lib/xfce4/xfconf/xfconfd
bryan    27963 27936  0 11:07 tty3     00:00:00 xfce4-session
bryan    27974 27963  0 11:07 tty3     00:00:00 xfce4-panel --display :3.0 --sm-
bryan    27984 27974  0 11:07 tty3     00:00:00 /usr/lib/x86_64-linux-gnu/xfce4/
bryan    27986 27974  0 11:07 tty3     00:00:00 /usr/lib/x86_64-linux-gnu/xfce4/
bryan    27988 27974  0 11:07 tty3     00:00:00 /usr/lib/x86_64-linux-gnu/xfce4/
bryan    27989 27974  0 11:07 tty3     00:00:01 /usr/lib/x86_64-linux-gnu/xfce4/
bryan    27993 27974  0 11:07 tty3     00:00:00 /usr/lib/x86_64-linux-gnu/xfce4/
bryan    28006     1  0 11:07 tty3     00:00:00 xfce4-settings-helper --display
bryan    28017     1  0 11:07 ?        00:00:00 xfce4-volumed

The package xfwm4 is installed, but even after doing an apt-get remove on xfwm4, I still get what appear to be xfwm4 key bindings when "exec startxfce4" is executed.

Thanks in advance for any help or insights on this problem!

Offline

#2 2015-10-04 22:00:06

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,505

Re: [Solved] "fvwm --replace" doesn't

The problem is that my fvwm key bindings appear to be overridden by those of xfwm4.

Can you give an example of which key bindings are overwritten?

Not sure if this will help, but the xfwm4 shortcuts are stored in the ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml file. You can remove them by going to the xfce4-settings-editor, xfce4-keyboard-shortcuts channel, xfwm4 properties tree, and delete (reset) them from there. That should free them up.

Online

#3 2015-10-05 16:14:59

bbatten
Member
Registered: 2015-10-04
Posts: 14

Re: [Solved] "fvwm --replace" doesn't

Hi ToZ. Thanks for the reply. I think I dragged a red herring into the discussion: I should have said mouse button bindings are overridden.

An example of an overridden binding is when I press the right mouse button while over the desktop. When fvwm bindings were working as expected, pressing and holding the right mouse button started tracing a line as you moved the mouse. So if you connect the dots corresponding to digits on your keypad, a rough representation of a letter, or any continuous line form, is created, which is then examined by the stroke library, which runs an associated command.

In my current situation,clicking on the right mouse button just pops up what looks like the standard xfce application menu.

Another example is that left clicking the mouse now does nothing instead of bringing up fvwm's root menu.

Some experiments I've done show that I can either get fvwm mouse button functions, but no panels, or panels but no fvwm mouse button functions.

So is modifying xfce4-keyboard-shortcuts.xml still applicable?

Thanks,

Offline

#4 2015-10-05 16:56:34

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,505

Re: [Solved] "fvwm --replace" doesn't

Xfce uses xfdesktop to manage the desktop. So if you click anywhere on the desktop, xfdesktop will intercept and process those events. You can try stopping xfdesktop as well via:

xfdesktop -Q

Note that you won't have anything managing your desktop after this. I'm not sure what fvwm uses as a desktop manager.

Online

#5 2015-10-05 21:00:37

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,115

Re: [Solved] "fvwm --replace" doesn't

ToZ wrote:

You can try stopping xfdesktop as well via:

xfdesktop -Q

At that point, with a different window manager and a different desktop manager, is the user even still using "Xfce DE," or something different that (possibly) has a mouse desktop background saved somewhere on the hard drive and (probably) has Thunar as a file manager?

What IS Xfce? And what portions of it - or at least percentage - must remain to still be Xfce?

NOTE: These are serious questions, but they are off-topic and the answering of them probably would not contribute to the solution of the OP's issue - so feel free to refrain from answering them unless/until bbatten has fixed his system. I was just curious and, well... I seem to have "CRS Syndrome" these days roll . Apologies.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#6 2015-10-05 23:24:45

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,505

Re: [Solved] "fvwm --replace" doesn't

The more you strip away the more watered down Xfce gets. If you look at the Xfce section of the git page, you'll see whats considered core Xfce. IMO, one of the nice things about Xfce is that you can do this and still end up with a functioning system. However, if you strip away the window manager (xfwm), the desktop manager (xfdesktop) and the session manager (xfce4-session) and supporting component/libraries, then I'd say you have something else with elements of Xfce in use.

Online

#7 2015-10-06 18:03:48

bbatten
Member
Registered: 2015-10-04
Posts: 14

Re: [Solved] "fvwm --replace" doesn't

As I think a little more about this, it seems to be the case that all the keyboard key bindings (e.g. CTL-ALT-Fx, SHIFT-<--left arrow) work. At least pressing the keys I use to switch virtual terminals and screens has the expected result.

So I suspect that my problem is really just the mouse button bindings. I tried

xfdesktop --quit

per your suggestion and found that I once again have my beloved fvwm mouse stroke library working. So it looks like I may be home free if I can just figure out at what point in the startup sequence to quit xfdesktop. My previous working configuration seemed to be oblivious to xfdesktop. Is there new or redefined functionality for xfdesktop4 as of Debian Wheezy version 4.8.3.2?

Also I took what should have been the obvious next step and verified that key bindings (e.g. CTL-ALT-Fx) have the same effect using just fvwm as when using xfdesktop. So I infer that fvwm has a parallel set of bindings.

Last edited by bbatten (2015-10-07 15:57:48)

Offline

#8 2015-10-06 18:11:06

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,505

Re: [Solved] "fvwm --replace" doesn't

You should be able to to go to Settings Manager >> Session and Startup >> Session tab, and change the "Restart Style" of xfdesktop to "Never".

If that doesn't work, try creating a /usr/local/bin/xfdesktop file with the following content:

#!/bin/bash
exit 0

...and make it executable. It will override the real xfdesktop file (/usr/bin/xfdesktop) and basically do nothing (which includes not starting xfdesktop).

Online

#9 2015-10-07 16:12:00

bbatten
Member
Registered: 2015-10-04
Posts: 14

Re: [Solved] "fvwm --replace" doesn't

"Settings Manager >> Session and Startup >> Session tab", then changing restart to "Never" does the trick.

Thanks very much for your help. I'd spent the better part of a month grinding away at this.

Thanks again.

Offline

Board footer

Powered by FluxBB