Xfce Forum

Sub domains

You are not logged in.

#1 2011-01-26 01:01:38

Registered: 2011-01-26
Posts: 2

Event sounds in XFCE 4.6.2 on Debian Sid

Hi, I am new to this forum, and have a question that I already posted on other forums, but didn't get a solution till now.
I recently changed to XFCE and I find it very good, so I will use it in the future.
Currently I am using XFCE 4.6.2 on Debian Sid (waiting for 4.8 to be released in Debian). All is working fine, except the event sounds. I enabled them under settings in the Appearance dialog. According to the tooltip in this dialog I also installed libcanberra, as sound-themes I tried freedesktop-sound-theme and moblin-sound-theme. But sadly I didn't get it to work.
As I have asked on other forums before, it was indicated that in Slackware XFCE even is compiled without support for event sounds, because they don't work there also. Regarding this, this seems not to be a distribution specific issue.

Maybe someone here can give a hint or a link to a tutorial how to enable the event sounds.
If it is not possible (I think it should work in 4.6?) with this version, will it work with 4.8?

Thanks in advance for any help.


#2 2011-01-26 22:28:54

From: ~
Registered: 2005-02-17
Posts: 1,144

Re: Event sounds in XFCE 4.6.2 on Debian Sid

Xfce on it's own has no support for sound, we only set a boolean to true in a public registry (xsettings) *another* is allowed to emit events. It works though a gtk module to emit the event, so the module needs to be loaded first (normally the distro does this for you) with something like this in xinitrc or console profile:

if [ -z "$GTK_MODULES" ] ; then



#3 2011-01-26 23:28:12

Registered: 2011-01-26
Posts: 2

Re: Event sounds in XFCE 4.6.2 on Debian Sid

Thanks for your help.

I tried your suggestion (copied your script to my rc.local, to get sure that it is executed for all users), but that sadly didn't work. I also tried to change the canberra-gtk-module to libcanberra-gtk-module (that is the name of the package in Debian) but that also didn't work.

Does that mean, that this is simply not supported in Debian, or am I doing something wrong?

Edit: I also tried to many change the setting for SoundThemeName in xsettings.xml from "default" to "freedesktop-sound-theme", but the after login xfce4-panel won't start. I am really stuck here.

Edit2: In the meantime I tried it with pulseaudio, in pavucontrol I have at least a slider for the volume of system-sounds, but that also didn't help.

Last edited by TobiSGD (2011-01-27 19:28:33)


Board footer

Powered by FluxBB