Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-05-12 23:39:37

Mellowbob
Member
Registered: 2011-10-16
Posts: 99

[Solved] Problems with Ubuntu and XFCE4-10

I recently installed ubuntu 14-4 and am having some "odd behaviour" with xfce.

First off is the volume indicator. It's in the panel and I can scroll the volume up/down by putting the mouse pointer on it and scrolling. Always works. However, if I reboot I can not use the multi-media scroll key on my keyboard until I log on and back in. Seems something is getting missed ???

Next, I can't seem to change the location or theme using in the notification popup. I can go to setting, and access the notifications option, but no changes take effect. It's stuck with a white text on black in the upper right.

Offline

#2 2014-05-12 23:57:58

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 2,832

Re: [Solved] Problems with Ubuntu and XFCE4-10

Mellowbob wrote:

I recently installed ubuntu 14-4 and am having some "odd behaviour" with xfce.

To confirm, Ubuntu+Xfce or Xubuntu?

First off is the volume indicator. It's in the panel and I can scroll the volume up/down by putting the mouse pointer on it and scrolling. Always works. However, if I reboot I can not use the multi-media scroll key on my keyboard until I log on and back in. Seems something is getting missed ???

Not sure about this one, but does clearing your sessions cache (Settings Manager >> Sessions and startup >> Session >> Clear saved sessions) help?

Next, I can't seem to change the location or theme using in the notification popup. I can go to setting, and access the notifications option, but no changes take effect. It's stuck with a white text on black in the upper right.

Which notification daemon are you using? To see:

ps -ef | grep notif

...if this is an Xfce on Ubuntu install, it may be the ubuntu notification-daemon that is running.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2014-05-13 00:16:59

Mellowbob
Member
Registered: 2011-10-16
Posts: 99

Re: [Solved] Problems with Ubuntu and XFCE4-10

ToZ wrote:
Mellowbob wrote:

I recently installed ubuntu 14-4 and am having some "odd behaviour" with xfce.

To confirm, Ubuntu+Xfce or Xubuntu?

It is Ubuntu + xfce. I fear that might be the problem smile

First off is the volume indicator. It's in the panel and I can scroll the volume up/down by putting the mouse pointer on it and scrolling. Always works. However, if I reboot I can not use the multi-media scroll key on my keyboard until I log on and back in. Seems something is getting missed ???

Not sure about this one, but does clearing your sessions cache (Settings Manager >> Sessions and startup >> Session >> Clear saved sessions) help?

No. I could not get sessions to stop saving on this install. So, I finally took the big bat out and changed the permissions on my .cache/sessions directory to read-only. And, it's empty.

Next, I can't seem to change the location or theme using in the notification popup. I can go to setting, and access the notifications option, but no changes take effect. It's stuck with a white text on black in the upper right.

Which notification daemon are you using? To see:

ps -ef | grep notif

...if this is an Xfce on Ubuntu install, it may be the ubuntu notification-daemon that is running.

[05:07 PM ~] bob$ ps -ef | grep notif
root        52     2  0 15:35 ?        00:00:00 [fsnotify_mark]
bob       7659  7429  0 16:31 ?        00:00:00 /usr/lib/evolution/3.10/evolution-alarm-notify
bob       7696  7429  0 16:31 ?        00:00:00 update-notifier
bob       7741  7429  0 16:31 ?        00:00:02 /usr/lib/x86_64-linux-gnu/notify-osd
bob       7890  7604  0 16:31 ?        00:00:00 /usr/lib/x86_64-linux-gnu/xfce4/panel/wrapper-1.0 /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/libsystray.so 4 27263022 systray Notification Area Area where notification icons appear
bob       9887  9833  0 17:07 pts/3    00:00:00 grep --color=auto notif

Assuming this is NOT the xfce notifier ... where can I disable this one and enable the correct one?

Offline

#4 2014-05-13 00:27:31

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 2,832

Re: [Solved] Problems with Ubuntu and XFCE4-10

Yep, notify-osd is the ubuntu notifier. You want xfce4-notifyd running. Look in Settings Manager >> Session and startup >> Application autostart and ~/.config/autostart to see if notify-osd is listed there. If so, remove it. If not, you may need to create a startup script that looks for and kills notify-osd and starts xfce4-notifyd. Something like:

#!/bin/bash
sleep 5
pkill notify-osd
/usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd

...assuming of course a 64bit install.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#5 2014-05-13 01:26:25

Mellowbob
Member
Registered: 2011-10-16
Posts: 99

Re: [Solved] Problems with Ubuntu and XFCE4-10

ToZ wrote:

Yep, notify-osd is the ubuntu notifier. You want xfce4-notifyd running. Look in Settings Manager >> Session and startup >> Application autostart and ~/.config/autostart to see if notify-osd is listed there. If so, remove it. If not, you may need to create a startup script that looks for and kills notify-osd and starts xfce4-notifyd. Something like:

#!/bin/bash
sleep 5
pkill notify-osd
/usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd

...assuming of course a 64bit install.

Getting closer. I can certainly kill off the notify-osd. Not sure where it's started from

But, I can kill it. And, I can start the "proper" notify. But, it dies after a few notifications:

(notification-daemon:13949): GLib-CRITICAL **: Source ID 16 was not found when attempting to remove it
Trace/breakpoint trap (core dumped)

Ideas?

Offline

#6 2014-06-04 21:25:30

Mellowbob
Member
Registered: 2011-10-16
Posts: 99

Re: [Solved] Problems with Ubuntu and XFCE4-10

Ahh, finally got it.

The problem is that ubuntu is starting up notify-osd. So, first we need to get rid of that. Easy, once one figures it out smile Simple do this:

   cd /usr/share/dbus-1/services
   sudo mv org.freedesktop.Notifications.service org.freedesktop.Notifications.service.disabled

and logout/in.

I'm assuming that you already have a file org.xfce.xfce4-notifyd.Notifications.service in the above directory. If you don't you'll need to create it, or start the notifier from startup services. So, if you don't have that file, easy to create with the contents:

[D-BUS Service]
Name=org.freedesktop.Notifications
Exec=/usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd

Hope this helps someone else!

Offline

Board footer

Powered by FluxBB