Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-05-20 03:28:09

mikesmithv
Member
Registered: 2016-05-20
Posts: 2

Ubuntu's overlay scrollbar remains in XFCE

I recently installed Ubuntu 16.04 as a fresh install, then added the XFCE packages and I see that the old "overlay scrollbars" are still there in all XFCE applications (like Thunar, XFCE Settings, XFCE Task Manager, etc.).  It has not been in Ubuntu since 15.10 so I was really disappointed to see it back in XFCE since that's become my preferred desktop lately.  Does anyone have any ideas on how to easily correct this?

I found that I can launch apps from the console by proceeding the app name with LIBOVERLAY_SCROLLBAR=0.  For example if I type "thunar" it launches the file manager with the awful overlay scrollbars but if I type "LIBOVERLAY_SCROLLBAR=0 thunar" I get the normal scrollbar.  So it appears there is a boolean somewhere to still allow the option of the overlay scrollbar in XFCE.  If I log out and log back in under Ubuntu there is no sign of the old overlay scrollbars - as if they never existed.  I'm sure there are solutions to modify or create launchers just for XFCE apps but I am wishing for an easier way.

Offline

#2 2016-05-20 04:10:32

mikesmithv
Member
Registered: 2016-05-20
Posts: 2

Re: Ubuntu's overlay scrollbar remains in XFCE

OK, I found the solution but it's not obvious.  To make a long story short, install unity-tweak-tool and click "Scrolling" and there are two radio buttons labeled "Overlay" and "Legacy".  Select "Legacy" and you're done.  I noticed this has no effect on standard Ubuntu scrollbars, they simply abandoned them and left the setting to "Overlay" for everyone else to mis-interpret.  Smart.

Here is the link where I got this info with more detailed steps.

Offline

#3 2016-05-21 16:13:53

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 163

Re: Ubuntu's overlay scrollbar remains in XFCE

I am really bugged by the overlay scrollbar which is back in xubuntu and is one of my most hated unity features, for nautilus and synaptic at least. I hesitate to add the unity tweak tool as it wanted to download a giant list of other unity stuff. Is there any other workaround?

Offline

#4 2016-05-21 20:22:20

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,858

Re: Ubuntu's overlay scrollbar remains in XFCE

cmcanulty wrote:

I am really bugged by the overlay scrollbar which is back in xubuntu and is one of my most hated unity features, for nautilus and synaptic at least. I hesitate to add the unity tweak tool as it wanted to download a giant list of other unity stuff. Is there any other workaround?

Add:

export GTK_OVERLAY_SCROLLING=0

..to ~/.bashrc (if you're using bash).

Offline

#5 2016-05-21 21:33:25

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 163

Re: Ubuntu's overlay scrollbar remains in XFCE

Thanks, I did that. I hope xfce doesn't let more of this stuff creep in. Thank you

Offline

#6 2018-09-11 04:39:06

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,019

Re: Ubuntu's overlay scrollbar remains in XFCE

ToZ wrote:
cmcanulty wrote:

I am really bugged by the overlay scrollbar which is back in xubuntu and is one of my most hated unity features, for nautilus and synaptic at least. I hesitate to add the unity tweak tool as it wanted to download a giant list of other unity stuff. Is there any other workaround?

Add:

export GTK_OVERLAY_SCROLLING=0

..to ~/.bashrc (if you're using bash).

I hate to revive an old thread, but wanted to ask if there is anything more required now that Xfce is partially "in GTK3 mode," and figured that someone doing a web search would end up at this thread anyway. A user (of Mint Xfce) on Mint's forum tried the above without success.

Thread is here:
https://forums.linuxmint.com/viewtopic. … 7&t=275300
if anyone would like to help directly.

Regards,
MDM

Last edited by MountainDewManiac (2018-09-11 04:39:53)


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#7 2018-09-11 12:15:45

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 163

Re: Ubuntu's overlay scrollbar remains in XFCE

I am still getting it in synaptic. I am running Xubuntu 18.04 64bit. It isn't listed as installed in synaptic

Offline

#8 2018-09-11 16:19:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,858

Re: Ubuntu's overlay scrollbar remains in XFCE

You can test whether it has an effect on individual apps by setting the environment variable before running the app. for example:

GTK_OVERLAY_SCROLLING=0 xed

...or:

GTK_OVERLAY_SCROLLING=0 synaptic

For me, the setting still works both from the command line and from within ~/.bashrc (caveat: you must be using bash for this location to work). I can only test this on Arch right now, but will have a look later when I have access to my Xubuntu system.

Offline

#9 2018-09-11 16:21:12

mint4all
Member
From: America
Registered: 2018-08-21
Posts: 68

Re: Ubuntu's overlay scrollbar remains in XFCE

Greetings!

@ MDM ... Nothing wrong with reviving an old topic -- extra help is always welcome smile

@ cmcanulty ... Anyway, i looked over my LM18.3-xfce everyday-workhorse, and the "GTK_OVERLAY_SCROLLING=0" variable is set; i have no idea how it is being set: there's no ~/.bashrc on my system, and the /etc/environment file does not contain it either. So i must assume that it was set by default (originally minted to LM18-xfce beta, then upgraded to .0, .1, .2, now 18.3).

I looked around a bit more and found that this variable was not set on my LM19.0-xfce laptop, and the overlay scrollbars (fade-in/-out) are in effect in both the Mint-X & -Y themes (confirmed this with Thunar, Synaptic & LibreOffice). Then i updated /etc/environment in root mode with this variable, rebooted, and now it worked perfectly: just as described @ https://bbs.archlinux.org/viewtopic.php?id=196118 (last reply), the fading scrollbars are gone. I will now go and check my other systems and make those updates if needed.

Imho, those fading scrollbars are a PITA especially for me: i prefer to position my primary panel vertically, in deskbar mode, along the right side of my widescreen displays. So that fixes one of my usability issues, and now i can auto-hide my right-side panel(s) and get that screen space back for my apps, ie in LO-Calc. Thanks a lot!

Cheers, M4A


Linux Mint 18.3-xfce & Linux Mint 19-xfce  -- Dell Precision T1500 Desktops -- Toshiba Satellite Laptop -- Family & Community Support re. Linux

Offline

#10 2018-09-11 21:48:53

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 163

Re: Ubuntu's overlay scrollbar remains in XFCE

ToZ I did the first command and got an error

cmcanulty@ubuntu1:~$ sudo GTK_OVERLAY_SCROLLING=0 xed
[sudo] password for cmcanulty:
sudo: xed: command not found
cmcanulty@ubuntu1:~$ GTK_OVERLAY_SCROLLING=0 synaptic

then I did the 2nd one with sudo and it seemed to work (it opened synaptic with a normal scrollbar, yea) but will it be permanent or do I have to do each time? What I don't understand as the overlay scrollbar isn't installed, I hate it, Thanks so much

Last edited by cmcanulty (2018-09-11 21:52:14)

Offline

#11 2018-09-12 00:41:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,858

Re: Ubuntu's overlay scrollbar remains in XFCE

Xubuntu (18.04) has it disabled by default, and GTK_OVERLAY_SCROLLING=0 is specified in /etc/X11/Xsession.d/56-xubuntu-session. I don't currently have access to a Mint install to check.

Maybe try something similar in Mint.

Offline

Board footer

Powered by FluxBB