Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-11-20 04:52:25

go123
Member
Registered: 2018-11-20
Posts: 1

xfce4-popup-applicationsmenu not working via key combo in Fedora29

hi all , just what the title says.
when i run xfce4-popup-applicationsmenu from a terminal, it works as expected.
Adding a key combo (Ctrl-Esc or Windows key) does not display it.

by the way,
when i run xfce4-whiskermenu-plugin via key combo, it works as expected.

thanks.

Offline

#2 2018-11-20 15:41:46

ToZ
Administrator
From: Canada
Registered: 2011-06-02
Posts: 9,524

Re: xfce4-popup-applicationsmenu not working via key combo in Fedora29

Hello and welcome.

Yes, there is something strange going on there. It seems to be broken for the built-in panel popup functions (applicationsmeny, windowmenu) but it works for whiskermenu.

I'm noticing the following:
1. The panel button depresses but the menu doesn't popup
2. In ~/.xsession-errors I get "(xfce4-panel:561): Gtk-WARNING **: 10:38:24.926: no trigger event for menu popup"
3. If I press the shortcut key again, it seems to ignore this shortcut and goes back to the default (possibly from /etc/xdg.....)
4. I need to click the panel icon to un-depress it to keep it from using the default shortcut.

I'll create a bug report for it.

Edit: bug report created.

Last edited by ToZ (2018-11-20 15:50:39)

Offline

Board footer

Powered by FluxBB