Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-10-04 14:05:55

Aravisian
Member
Registered: 2019-08-17
Posts: 132

(Solved) Roll XFCE 4.14 back to 4.12

I have read some guides that cover doing so if you have 4.12 and then install 4.14. However, I would like to know if you can roll back to 4.12 if you install a newly released distro that comes with 4.14 packaged in.

Last edited by Aravisian (2019-10-10 05:06:28)

Offline

#2 2019-10-04 15:39:19

alcornoqui
Member
Registered: 2014-07-28
Posts: 473

Re: (Solved) Roll XFCE 4.14 back to 4.12

If the distro still packages the previous version, isn't it a question of forcing, then locking the desired packages?

For example, in Synaptic, Package > Force version & Package > Lock version. I assume other distros and package managers have something akin. You still could get in some dependency trouble along the way, of course...

Just my two cents as an average user, I'd be happy to hear from others.

Source, with more details for apt based distros: https://askubuntu.com/questions/18654/h … ic-package

PS: I'm loving 4.14, what's your reason for rolling back? Or do you just want to know how to do it if needed?

Offline

#3 2019-10-04 18:14:59

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Roll XFCE 4.14 back to 4.12

alcornoqui wrote:

PS: I'm loving 4.14, what's your reason for rolling back? Or do you just want to know how to do it if needed?

This.

I have only lightly tested 4.14 but what I experienced was gtk3 heavy. The entire appeal for me in migrating (With jumping joy) to XFCE was in being a liberated Gnome refugee.
Gnome kinda takes the fun out of ditching Microsoft when it's just like it.
I also looked into Mate, but a person can only resist the changing times for so long... Mate now uses GTK3, as well.

I meant to ask; would updates from the distro override rolling back to xfce 4.12?

Last edited by Aravisian (2019-10-05 06:32:37)

Offline

#4 2019-10-10 05:08:10

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Roll XFCE 4.14 back to 4.12

alcornoqui wrote:

If the distro still packages the previous version, isn't it a question of forcing, then locking the desired packages?

For example, in Synaptic, Package > Force version & Package > Lock version.

I installed newest version of Distro, then installed the XFCE Desktop of my preference.  Followed your instructions and locked it in using Synaptic
Thanks for sharing the how-to on that. I had no idea that option was there.

Offline

#5 2019-10-10 07:29:31

alcornoqui
Member
Registered: 2014-07-28
Posts: 473

Re: (Solved) Roll XFCE 4.14 back to 4.12

Beware of the caveats:

Lock version is not as clever as it sounds. It's supposed to do what it says on the tin, lock the version... But it only locks it within Synaptic. Anything else that does package upgrades (read: Update Manager, apt-get, aptitude, etc) ignores this. This is probably buggy behaviour so I would expect this to be fixed in time.

From What does 'Lock Version' do?. It's an interesting read!

Offline

#6 2019-10-10 22:13:17

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Roll XFCE 4.14 back to 4.12

alcornoqui wrote:

Beware of the caveats:

Lock version is not as clever as it sounds. It's supposed to do what it says on the tin, lock the version... But it only locks it within Synaptic. Anything else that does package upgrades (read: Update Manager, apt-get, aptitude, etc) ignores this. This is probably buggy behaviour so I would expect this to be fixed in time.

From What does 'Lock Version' do?. It's an interesting read!

You are awesome, thanks for helping me through that.
I did the full upgrade then removed the latest Whisker menu. I downloaded the .deb file for the Xenial version, which suits my purposes perfectly.  Then followed the instructions in your link to hold it back. Performed a dist-upgrade and upgrade. Everything is working flawlessly, now, gtk3.24 with XFCE 4.12 and Whiskermenu 1.5.1

Offline

#7 2019-10-11 19:09:16

alcornoqui
Member
Registered: 2014-07-28
Posts: 473

Re: (Solved) Roll XFCE 4.14 back to 4.12

Haha, cool, thanks!

For the record, I search the web with DuckDuckGo.

Offline

#8 2019-10-11 20:24:05

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Roll XFCE 4.14 back to 4.12

alcornoqui wrote:

Haha, cool, thanks!

For the record, I search the web with DuckDuckGo.

Of course- on Waterfox big_smile

Offline

Board footer

Powered by FluxBB