Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-09-08 09:27:21

foxium
Member
Registered: 2020-09-08
Posts: 2

Can't save sessions (solved)

I'm running Xfce with LightDM on Clear Linux, and I have not been able to save sessions since initial installation. I am new to Xfce but not to Linux.

The program list inside the Session and Startup > Current Session tab is always empty. Clicking the "Save Session" button results in the following dialog:

Your session is being saved. If you do not wish to wait, you may close this window.

This dialog box, if left open, seems to last forever (tried waiting for 15 minutes before giving up). No session file is created in ~/.cache/sessions/.

Clicking on the Save Session button again results in the following error:

GDBus.Error:org.xfce.SessionManager.Error.Failed: Session manager must be in idle state when requesting a checkpoint

Permissions on the session directory seems to be fine:

$ ls -l ~/.cache | grep sessions
drwx------   3 foxium foxium     4096 Sep  7 14:45 sessions

Manually creating ~/.cache/sessions/xfce4-session-foxium-thinkpad:0 with permissions 700 and 770 (tried both) results in a "Saved Sessions" tab shown in Session and Startup. This tab however shows no saved session, as expected. Clicking the clear saved sessions button in this tab removes the manually created session file.

I've looked at ~/.xsession-errors, dmesg, and journalctl. There isn't any error/warning is logged before/after clicking the Save Session button.

Here are the packages' versions:

$ xfce4-session --version | grep xfce4-session
xfce4-session 4.14.1 (Xfce 4.16pre1)

$ lightdm --version
lightdm 1.30.0

$ X -version
X.Org X Server 1.20.8
X Protocol Version 11, Revision 0
Build Operating System: Linux 5.7.8-968.native x86_64
Current Operating System: Linux foxium-thinkpad 5.7.19-982.native #1 SMP Tue Sep 1 09:10:05 PDT 2020 x86_64
Kernel command line: initrd=\EFI\org.clearlinux\initrd-org.clearlinux.native.5.7.19-982 initrd=\EFI\org.clearlinux\freestanding-00-intel-ucode.cpio initrd=\EFI\org.clearlinux\freestanding-clr-init.cpio.gz initrd=\EFI\org.clearlinux\freestanding-i915-firmware.cpio.xz root=UUID=1b994ad2-737b-493c-8f11-9b4ba323353e rd.luks.uuid=03b00b44-ff62-47bd-9802-17bd564b3748 quiet console=tty0 console=ttyS0,115200n8 cryptomgr.notests init=/usr/bin/initra-desktop initcall_debug intel_iommu=igfx_off kvm-intel.nested=1 no_timer_check noreplace-smp page_alloc.shuffle=1 rcupdate.rcu_expedited=1 rootfstype=ext4,btrfs,xfs,f2fs tsc=reliable rw rootflags=x-systemd.device-timeout=0 module.sig_unenforce rd.luks.options=discard
Build Date: 31 July 2020  06:03:59PM

Current version of pixman: 0.38.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.

Is there any way I can enable more logging to pinpoint the problem's source?

Any help or hint is highly appreciated.

Last edited by foxium (2020-09-08 09:42:53)

Offline

#2 2020-09-08 09:43:56

foxium
Member
Registered: 2020-09-08
Posts: 2

Re: Can't save sessions (solved)

Turns out iceauth was missing. Problem has been resolved by installing iceauth through the os-utils-gui bundle:

swupd bundle-add os-utils-gui

Offline

Board footer

Powered by FluxBB