Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-10-03 19:21:18

alcornoqui
Member
Registered: 2014-07-28
Posts: 739

[SOLVED] Thunar: Some custom keyboard shortcuts not working

Hello there! Some time ago (not really sure when, some months ago for sure), the custom key combos I use to sort files in Thunar stopped working. The only other custom combo I use (for a custom action) still works.

These are the modified lines in ~/.config/Thunar/accels.scm

(gtk_accel_path "<Actions>/ThunarActions/uca-action-1568964076674115-1" "<Primary><Shift>e")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-name" "<Primary><Shift>1")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-size" "<Primary><Shift>2")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-descending" "<Primary><Shift>5")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-type" "<Primary><Shift>3")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-ascending" "<Primary><Shift>6")

Here's the full accels.scm.

I'm following the instructions at the official Thunar FAQ.

The strangest thing is that the combos show in Thunar itself! See:
VwyhSSo.png

But they don't work sad Only the custom action does...

Any ideas?

OS: Ubuntu 18.04.5 LTS x86_64
Xfce 4.14 from Xubuntu QA Staging PPA
Thunar 1.8.15

Last edited by alcornoqui (2020-10-04 21:33:01)

Offline

#2 2020-10-03 21:47:39

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,076

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

Hmm. Doesn't work for me either. Looks like a bug.

Online

#3 2020-10-03 22:10:29

alcornoqui
Member
Registered: 2014-07-28
Posts: 739

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

A Thunar bug, I suppose?

I'll report it.

Offline

#4 2020-10-03 22:11:49

MrEen
Member
Registered: 2019-04-19
Posts: 243

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

Is it possible you need to set and use "<Actions>/ThunarStandardView/arrange-items-menu" "") as well?

Offline

#5 2020-10-03 22:20:45

alcornoqui
Member
Registered: 2014-07-28
Posts: 739

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

MrEen wrote:

Is it possible you need to set and use "<Actions>/ThunarStandardView/arrange-items-menu" "") as well?

Thanks for chiming in. I tried to set it to Ctrl+Shift+7, didn't work.

Then I tried just uncommenting the default setting (""), didn't work either.

I'm reporting the bug...

Offline

#6 2020-10-03 22:23:02

alcornoqui
Member
Registered: 2014-07-28
Posts: 739

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

Offline

#7 2020-10-04 15:22:26

alcornoqui
Member
Registered: 2014-07-28
Posts: 739

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

So, the solution was to substitute the 123456 keys I used to the keyname of the character corresponding to Shift+123456 (in my case !"·$%& -- yours may differ).

The names I needed were:

1: exclam for !
2: quotedbl for "
3: periodcentered for ·
4: dollar for $
5: percent for %
6: ampersand for &

And then one has to ignore the <Shift> in the accels.scm file, like this:

(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-name" "<Primary>exclam")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-size" "<Primary>quotedbl")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-descending" "<Primary>ampersand")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-type" "<Primary>periodcentered")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-ascending" "<Primary>percent")
(gtk_accel_path "<Actions>/ThunarStandardView/sort-by-mtime" "<Primary>dollar")

All of them are working now, it's so nice to have them back!

Offline

#8 2020-10-04 15:23:32

alcornoqui
Member
Registered: 2014-07-28
Posts: 739

Re: [SOLVED] Thunar: Some custom keyboard shortcuts not working

As a result of the bug report, this behavior has been documented in the official Thunar FAQ:

The custom keyboard shortcuts are stored in the standard GTK+ accel map format in a file located at $XDG_CONFIG_HOME/Thunar/accels.scm. Lines starting with ; are comments. See the GTK+ documentation for details about the file format.

Note that for some keys the <Shift> modifier seems to be ignored. (E.g. <Primary><Shift>1 fails, where <Primary>exclam works fine.) Most likely a gtk bug.

Check the keynames.txt for a list of available keys.

So... solved! Thank y'all!

Last edited by alcornoqui (2020-10-04 21:32:09)

Offline

Board footer

Powered by FluxBB