Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-10-07 08:34:06

fant
Member
Registered: 2020-10-07
Posts: 8

suspend not working as should with XFCE 4.14

Hello,
I'm new to this forum and, let's say, not an experienced Linux User.

System:
  Hardware: Thinkpad T410
  OS: Linux Mint 20 XFCE 4.14
  System up to date, kernel 5.4.0-48

Problem:
I experience a SUSPEND issue with XFCE 4.14 which not occurs with XFCE 4.12.

When I suspend, the screen goes blank, but e.g. keyboard etc. still active (thus the Laptop is still running), but I can't resurrect the system. I need to hard reset. No suspend.

I searched a lot in the internet and tried several solutions (so I probably confused my installation ;-).
I edit policys, edit light-locker, removed light-locker and serveral, tried an older kernel, edit BIOS, set BIOS to default and other tweaks which I gathered all over the internet.

But issue still present.
So to say, I'm no step further in this regard - so, want to ask for help.


Do some of you experience the same issue?
Is it related to XFCE 4.14?
Can you provide a solution?

Thanks a lot.

Last edited by fant (2020-10-07 08:45:01)

Offline

#2 2020-10-07 10:33:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: suspend not working as should with XFCE 4.14

Hello and welcome.

Can we see some log files? Attempt a suspend and make note of the date/time that you are doing this.
Then after you restart your computer and log back in, run the following command:

sudo journalctl -b -1 --no-pager > /tmp/suspend.log

...and post back both the day/time of the suspend attempt and the contents of /tmp/suspend.log.

Offline

#3 2020-10-07 11:20:52

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

I suspended on 12:52:30 with the same described issue.

Please find following the requested contend of  journalctl

I understand 10% - hopefully there are no secrets in it ;-)

-- Logs begin at Mon 2020-10-05 19:33:37 CEST, end at Wed 2020-10-07 12:55:33 CEST. --
...

BTW, on this machine I run Mint 19 Cinnamon before, also Debian 10 XFCE 4.12 and Gnome from an external harddrive. No issues on all three in this regard. This is the reason why I suspect that the issue comes from XFCE 4.14

Last edited by fant (2020-10-10 14:48:24)

Offline

#4 2020-10-07 12:26:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: suspend not working as should with XFCE 4.14

This gives us the log after the restart. Sorry but I've misunderstood the man page. Can you do the same again but with this command:

sudo journalctl -b -2 --no-pager > /tmp/suspend.log

I want to see the log entries heading into 12:52:30

Offline

#5 2020-10-07 12:49:59

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: suspend not working as should with XFCE 4.14

After reviewing your first log file, a few more questions:

1. Is this an optimus based system (nvidia/intel dual GPUs)?
2. If so, for the other Distros/DEs that you ran, did you use the nvidia drivers or noveau drivers? Which drivers are you using now?

And finally, can you follow the steps from this page to see if we can identify the driver/device that is preventing the successful restore? Specifically, run this commands:

sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"

...and then on restart of the system, look for "Magic Number" and "hash matches" entries in dmesg.

My first guess is that this probably isn't an Xfce issue but rather a system issue, but its odd that it works with the other DEs and Xfce 4.12. Lets see what we can find out.

Offline

#6 2020-10-07 17:27:39

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

ToZ, thanks a lot!

I read the manpage of journalctl and I think your first approach was correct. After the -b its a number and not a letter. With my first try I used an "-l" instead of a "-1". Sorry for that.

Now, started from scratch, I'm pretty sure, that I post the right journal content:

Time of suspend: 18:53:30
Last lines of journalctl with -b -1:

Okt 07 18:52:39 fant-ThinkPad-T410 systemd[1289]: Starting Evolution address book service...
Okt 07 18:52:40 fant-ThinkPad-T410 dbus-daemon[1305]: [session uid=1000 pid=1305] Successfully activated service 'org.gnome.evolution.dataserver.AddressBook10'
Okt 07 18:52:40 fant-ThinkPad-T410 systemd[1289]: Started Evolution address book service.
Okt 07 18:53:30 fant-ThinkPad-T410 NetworkManager[851]: <info>  [1602089610.2261] manager: sleep: sleep requested (sleeping: no  enabled: yes)
Okt 07 18:53:30 fant-ThinkPad-T410 NetworkManager[851]: <info>  [1602089610.2263] manager: NetworkManager state is now ASLEEP
Okt 07 18:53:30 fant-ThinkPad-T410 systemd[1]: Reached target Sleep.
Okt 07 18:53:30 fant-ThinkPad-T410 systemd[1]: Starting Suspend...

Thats it - EndOfFile so to say.

With the parameters -b -2 it starts as usual with

-- Logs begin at Mon 2020-10-05 19:33:37 CEST, end at Wed 2020-10-07 18:56:54 CEST. --
Okt 07 18:55:11 fant-ThinkPad-T410 kernel: microcode: microcode updated early to revision 0x7, date = 2018-04-23
Okt 07 18:55:11 fant-ThinkPad-T410 kernel: Linux version 5.4.0-48-generic (buildd@lcy01-amd64-010) (gcc version 9.3.0 (Ubuntu 9.3.0-10ubuntu2)) #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020 (Ubuntu 5.4.0-48.52-generic 5.4.60)
...

... and so on.

<<1. Is this an optimus based system (nvidia/intel dual GPUs)?>>

yes, it has a nvidia chipset

<<2. If so, for the other Distros/DEs that you ran, did you use the nvidia drivers or noveau drivers? Which drivers are you using now?>>

I use xserver-xorg-video-nouveau on all installations.

<<My first guess is that this probably isn't an Xfce issue ...>>

After I installed the current Manjaro XFCE 4.14 I experienced exactly the same issue... thus I dare to say, that it depends on XFCE.


Thanks ToZ - I learned a lot... :-)

Offline

#7 2020-10-07 17:37:38

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

with

sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"

the same issue occurs.

Content of pm_trace:

0

Whatever that means :-))

Last edited by fant (2020-10-07 17:39:00)

Offline

#8 2020-10-07 19:27:21

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: suspend not working as should with XFCE 4.14

fant wrote:

with

sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"

the same issue occurs.

Content of pm_trace:

0

Whatever that means :-))

Follow this process again, and when you recover, post back the results of:

dmesg | grep -E 'Magic|hash match'

After I installed the current Manjaro XFCE 4.14 I experienced exactly the same issue... thus I dare to say, that it depends on XFCE.

It sure looks like it, doesn't it? I don't understand how though - Xfce just uses existing system suspend methods.

Can you also try the following:

xfce4-power-manager -Q
xfce4-power-manager --no-daemon --debug > $HOME/power.log 2>&

...then suspend. When you recover the computer, post back the contents of the power.log file in your home directory.

Also, what display manager and screensaver are you using? Are you able to Ctrl+Alt+F3 and get a text console?

Offline

#9 2020-10-08 17:05:01

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

Result of $ dmesg | grep -E 'Magic|hash match'

[    0.876840] PM:   Magic number: 8:658:992
[    0.876945] memory memory35: hash matches

Whatever that means. I wonder, that I have a magic memory installed lol

- Xfce just uses existing system suspend methods.

Sure, but I never had a similar issue with any Linux on my T410... - started with Debian 6 (Squeeze).

Content of the power.log:

Xfce-Energieverwaltung: Eine andere Energieverwaltung läuft bereits

-> means, that another power-managment is already running

Probably this is the reason for the issue???
'tlp' came in mind, but it's not installed.
I disabled the BIOS power-management - no success.
Also, I have no idea why an other powermanager should be running...


Also, what display manager and screensaver are you using?

lightdm
light-locker

Are you able to Ctrl+Alt+F3 and get a text console?

Yes

Hm, I've never been so persistent - probably thats because I like XFCE a lot smile
Won't give up...

Last edited by fant (2020-10-08 17:28:01)

Offline

#10 2020-10-08 18:25:11

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 7,119

Re: suspend not working as should with XFCE 4.14

fant wrote:

Are you able to Ctrl+Alt+F3 and get a text console?

Yes

So the system is returning from sleep, but you have a blank screen. I believe there is a light-locker bug about this. Try typing in your password blindly to see if it lets you through. Maybe also try another screensaver (either xscreensaver of xfce4-screensaver - just make sure you disable light-locker when you try).

Offline

#11 2020-10-09 11:05:13

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

ToZ wrote:

Are you able to Ctrl+Alt+F3 and get a text console?

So the system is returning from sleep, but you have a blank screen.

I think there was an misunderstanding on my side.
Had you intended that I try CTRL+ALT+F3 after suspending? If so, this is not working. It works only when in normal operation mode.

I tried some live distros (USB stick). Some with lightdm and gdm. All distros are using 5.* kernels (Fedora 32, Mint Cinnamon and XFCE, Manjaro Gnome). With all of those, the issue occurs.
With my installed Mint.XFCE I switched from the pre-installed lightdm to XDM. Result: no proper suspend and I end up in a mess sad  - 'timeshift' helped me out.

After all that I suspect that this issue has to do with the kernel.
Why, because with Debian XFCE 4.12 all works fine. The kernel version starts with 4.*

What me also worries, is that suspend with the live distros is working pretty well on my daughters, much better and newer, device big_smile
If my suspect is right, I can only hope that this will be corrected for newer kernels soon, so that the good old, tried and tested Thinkpads can cope with new distros.

Do you think my suspect is reasonable?
Do you know, where at best this information could be placed, so that the kernel developers will know about this issue?

Thanks for your efforts!

BTW, I will try the other screensavers - will come back with the result ...

Offline

#12 2020-10-09 11:34:25

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

ToZ wrote:

Maybe also try another screensaver (either xscreensaver of xfce4-screensaver - just make sure you disable light-locker when you try).

Tried. Light-locker does not seem to be the cause.

Offline

#13 2020-10-10 14:40:18

fant
Member
Registered: 2020-10-07
Posts: 8

Re: suspend not working as should with XFCE 4.14

I installed kernel 4.16 - suspend now works flawlessly...

one of the sources: https://forums.linuxmint.com/viewtopic.php?t=309824 (Suspend fails since Kernel 5.3.0-26)

I am curious what other problems will arise as a result big_smile

Thanks again...

Last edited by fant (2020-10-10 14:43:06)

Offline

Board footer

Powered by FluxBB